[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] chroot to ARM Gentoo install.

From: James Pellow
Subject: Re: [Qemu-devel] chroot to ARM Gentoo install.
Date: Tue, 24 Aug 2004 15:44:59 -0700
User-agent: KMail/1.7

On Tuesday 24 August 2004 01:06 pm, Paul Brook wrote:
> On Tuesday 24 August 2004 20:38, James Pellow wrote:
> > Hi All,
> >
> > Thanks for a truely awesome tool!  I have some custom ARM hardware that I
> > have ported the linux kernel to, and for fun I want to install Gentoo on
> > it. Since gentoo requires a fair piece of compiling (gasp...) and since
> > my board only runs at 74MHz, I thought I would try chroot'ing into ARM
> > gentoo using qemu on my Athlon system.  (Yes, I have tried distcc...  Its
> > still slow.)  I have been able to set up binfmt_misc and a statically
> > compiled qemu-arm to chroot into an arm busybox install (uClibc), but for
> > some reason I get the following error when I try to chroot into a gentoo
> > root (full glibc):
> You might see if the this patch helps:
> http://lists.gnu.org/archive/html/qemu-devel/2004-08/msg00015.html
> You don't mention what sort of ARM chip you are using. qemu only supports
> armv4. It does not currently implement the armv4t or armv5 instruction
> sets. I have patches implementing armv5te, but they still need testing.
> Paul

Hi Paul,

Thanks for the quick reply.  I am using an armv4 chip, specifically an 
arm720tdmi.  All code has been built for armv4.

I tried the patch you pointed me to.  Unfortunately I am still seeing the same 
results as previously noted.  Looking at the source for ld.so, I note that 
this is all happening in the elf parsing code.  The actual assert looks like:

      assert (info[DT_PLTREL]->d_un.d_val == DT_REL
              || info[DT_PLTREL]->d_un.d_val == DT_RELA);

for the case where !ELF_MACHINE_NO_RELA && !ELF_MACHINE_NO_REL are not 
defined...  That didn't make much sense to me yet, as I haven't poked around 
in glibc much.  Its hard for me to imagine that the problem is in glibc 
though since it shouldn't know the difference between running natively and 
running under qemu. (Or is there a subtle difference?)  It more obviously 
seems like elf should parse same either in emulation or not.  Since qemu 
doesn't signal, how should I procede in debugging this?  Any further ideas?  
Thanks for your help.


James Pellow, President
Alent Design Solutions

reply via email to

[Prev in Thread] Current Thread [Next in Thread]