[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] ne2k brokenness

From: Marcus Brinkmann
Subject: [Qemu-devel] ne2k brokenness
Date: Thu, 07 Oct 2004 04:17:05 +0200
User-agent: Wanderlust/2.10.1 (Watching The Wheels) SEMI/1.14.6 (Maruoka) FLIM/1.14.6 (Marutamachi) APEL/10.6 Emacs/21.3 (i386-pc-linux-gnu) MULE/5.0 (SAKAKI)


(Please CC me on reply, I am not subscribed).

the NE2K driver has serious issues, assuming that GRUB's ns8390 driver
is correct (as it works on real hardware, the assumption is reasonable
in the context of emulation, I'd guess).

I have set up a tun device (which works fine in Bochs).  I have setup
a GRUB 0.95 (actually, 0.95 with some CVS fixes as used in Debian)
netboot floppy image with the ns8390 driver enabled (NE2000 PCI).  I
have reused an old hdimage of mine, which I used at some time with an
older version of qemu.

I compiled qemu CVS of 2004-10-06, but also tried qemu 0.6.0.  I
didn't try older versions.  I use GNU/Linux as my host OS, Linux
kernel version is 2.6.7-1-686 (stock Debian kernel).  I have an Intel
P4 2.8GHz processor.

This is my command line:

$ qemu -m 128 -boot a -fda ~/.bochs/grub-0.95-i386-pc.ext2fs \
-hda ~/.bochs/guest.hd0 -n /home/marcus/gnu/bochs/start-tun

This will set up the tun device and bring up GRUB.  However, GRUB
fails to detect the NIC.  Oops.

Now, here is the weird thing, and the only hint I have to the problem:
If I run the same command as above under "strace", it works!  At least
up to the point of detecting the NIC, downloading the menu.lst file
via tftpboot, and starting to download the kernel etc.  It was too
slow to test further, but it seemed to make progress.

I don't have time to do serious debugging (not within the next two
weeks anyway), but I am happy to test what you throw at me, or try
some stuff if you can give some pointers.

My goal is to use qemu instead bochs for developing the GNU/Hurd port
to the L4 microkernel.  It's absolutely essential that I can just drop
my stuff into the tftpboot directory and test it quickly.  Bochs 2.1
can't even boot L4 anymore, it's a misery ;)

The speed advantage of using qemu (over Bochs) is an extra bonus.
Keep it up, guys.  Very impressive progress in the last months.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]