[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Problem compiling QEMU with VNC support

From: Magnus Damm
Subject: Re: [Qemu-devel] Problem compiling QEMU with VNC support
Date: Sun, 24 Oct 2004 20:40:38 +0200


It looks like you are building qemu-fast. I'm no expert on qemu-fast but
generally, creating static binaries requires static libraries. You write
that you found a file called something like "libm.so" in "/lib", but
what you probably should look for when compiling a static binary is a
file called "libm.a". My system has that file in "/usr/lib".

The easiest solution is probably to use the softmmu version instead of

/ magnus

On Sun, 2004-10-24 at 16:44, Juan Jose Costello Levien wrote:
> Hello,
> I am trying to compile QEMU from CVS using the rfb9
> patch that Johannes Schindelin provided. The scenario
> is this:
> . Try to compile on a Mandrake 10 box.
> . Have compiled SDL from sources (1.2.7) with success.
> . Have installed LibVNCserver with success. (0.7pre).
> . Downloaded QEMU sources with CVS.
> . Patched the CVS sources with the rfb0 patch.
> The error when I try to compile the program is about
> the libm library (it doesn't find it). I searched the
> /lib dir and there it is (libm-2.3.3.so). The output
> of the make command is this:
> address@hidden i386]# make
> gcc  -static -Wl,-T,/tmp/qemu/qemu/i386-vl.ld  -o
> qemu-fast vl.o osdep.o block.o readline.o monitor.o
> pci.o console.o block-cow.o block-qcow.o aes.o
> block-vmdk.o block-cloop.o ide.o ne2000.o pckbd.o
> vga.o sb16.o dma.o oss.o fdc.o mc146818rtc.o serial.o
> i8259.o i8254.o pc.o cirrus_vga.o gdbstub.o vnc.o
> sdl.o slirp/cksum.o slirp/if.o slirp/ip_icmp.o
> slirp/ip_input.o slirp/ip_output.o slirp/slirp.o
> slirp/mbuf.o slirp/misc.o slirp/sbuf.o slirp/socket.o
> slirp/tcp_input.o slirp/tcp_output.o slirp/tcp_subr.o
> slirp/tcp_timer.o slirp/udp.o slirp/bootp.o
> slirp/debug.o slirp/tftp.o libqemu.a  -lm -lz
> -L/usr/lib -lSDL -lpthread -lm  -ldl -lasound -laudio
> -lXt -L/usr/X11R6/lib -lX11 -lXext -L/usr/local/lib
> -lvncserver -lnsl -lpthread -ljpeg -lz -lutil
> /usr/bin/ld: cannot find -lm
> collect2: ld returned 1 exit status
> make: *** [qemu-fast] Error 1
> The error is in the i386 dir.
> I tried to change some configure scripts, some
> makefiles but seems to take no effect. The changes I
> made were with the -I flag to support the /lib dir,
> but nothing (I worked very little with makefiles).
> Hope someone helps.
> Thanks.
> Juan
> ___________________________________ 
> ¡Llevate a Yahoo! en tu Unifón! 
> Ahora podés usar Yahoo! Messenger en tu Unifón, en cualquier momento y lugar. 
> Encontrá más información en: http://ar.mobile.yahoo.com/sms.html
> _______________________________________________
> Qemu-devel mailing list
> address@hidden
> http://lists.nongnu.org/mailman/listinfo/qemu-devel

reply via email to

[Prev in Thread] Current Thread [Next in Thread]