[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Qemu won't cold boot XP

From: Jason Brittain
Subject: [Qemu-devel] Qemu won't cold boot XP
Date: Mon, 25 Oct 2004 08:58:21 -0700
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040913

Hi there Qemu enthusiasts.  :)

First, some background info:

Qemu:  0.6.0 - CVS HEAD
Guest: Fedora Core 2 Linux
Host:  WinXP Corp.

I get all the way through the installation, qemu warm reboots
and it goes through some configuration, warm reboots again,
then actually does run WinXP (beautiful).  I get to the desktop
and can run programs and configure the system.  I can even do
warm reboots and get all the way back to the desktop again, as
long as I don't shut down qemu.

But, as soon as I shut qemu down and try to restart it, then
it doesn't boot anymore.

With a regular image hard drive file (non-COW), created via
qemu-img, I get the boot screen saying:

A disk read error occurred
Press Ctrl+Alt+Delete to restart

And running all the way through the same exact test with a COW
image, created via qemu-mkcow, I get:

address@hidden qemu]# qemu -hda xp.cow
Connected to host network interface: tun0
Segmentation fault

Also, after these images are in this state, I tried various versions
of qemu including 0.6.0 and each of them does the above.  No
difference.  Also, the command line arguments don't seem to matter
either.  I tried various permutations of networking, -isa, larger
memory, with/without CDROM, etc.  Also, the same qemu installations
run Linux as a guest OS just fine (well, except that network port
redirections don't work at all, which I'll probably also mail you



Jason Brittain

reply via email to

[Prev in Thread] Current Thread [Next in Thread]