[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Build errors

From: James Boddington
Subject: Re: [Qemu-devel] Build errors
Date: Tue, 26 Oct 2004 08:09:21 +1000
User-agent: Mozilla Thunderbird 0.8 (X11/20040913)

Thomas Schwinge wrote:

Yesterday, I tried to build the latest CVS version of QEMU, but failed:

CFLAGS set to '-Os -pipe -march=athlon-xp'
gcc -I/package/misc/spf/qemu-20041024T153139Z-1/spf/sdl/include 
-I/package/misc/spf/qemu-20041024T153139Z-1/spf/zlib/include -O2 
-fno-strict-aliasing -Os -pipe -march=athlon-xp -fomit-frame-pointer -I. 
-I/tmp/build/qemu/qemu-20041024T153139Z -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 
-D_LARGEFILE_SOURCE -I/tmp/build/qemu/qemu-20041024T153139Z/slirp -c -o 
helper2.o /tmp/build/qemu/qemu-20041024T153139Z/target-i386/helper2.c
/tmp/build/qemu/qemu-20041024T153139Z/softmmu_template.h: In function 
/tmp/build/qemu/qemu-20041024T153139Z/softmmu_template.h:223: error: unable to 
find a register to spill in class `GENERAL_REGS'
/tmp/build/qemu/qemu-20041024T153139Z/softmmu_template.h:223: error: this is 
the insn:
(insn:HI 306 426 307 13 (parallel [
            (set (reg:DI 0 ax [176])
                (lshiftrt:DI (reg/v:DI 59 [ val ])
                    (subreg:QI (reg:SI 185) 0)))
            (clobber (scratch:SI))
            (clobber (reg:CC 17 flags))
        ]) 306 {lshrdi3_1} (nil)
    (expr_list:REG_UNUSED (reg:CC 17 flags)
        (expr_list:REG_UNUSED (scratch:SI)
/tmp/build/qemu/qemu-20041024T153139Z/softmmu_template.h:223: confused by 
earlier errors, bailing out
make[1]: *** [helper.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory 
make: *** [all] Error 1

I get the same error when I try -march=athlon-xp with gcc 3.4.2 and a simillar error when I try the same CFLAGS with gcc 3.3.5.

I am wondering if this a bug in qemu or is qemu triggering a bug in gcc? Searching http://gcc.gnu.org/bugzilla/ for "unable to find a register to spill in class" does show some gcc related errors.

The highest march I can use without getting a compile error is -march=pentium. I am not having any problems using mtune or mcpu.

I just compiled qemu with

make CFLAGS="-O2 -mtune=athlon-xp -fomit-frame-pointer"

using gcc 3.4.2. It installed ok and runs the linux image I have been playing with.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]