[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] qemu 32 bits on AMD64

From: Bob Deblier
Subject: Re: [Qemu-devel] qemu 32 bits on AMD64
Date: Mon, 07 Mar 2005 13:47:52 +0100

On Mon, 2005-03-07 at 07:41 -0500, address@hidden wrote:
> I have read the posts about the gcc "internal compiler error: Segmentation 
> fault" on x86_64. ok. I have just tried with CVS (7 feb 2005 ) . I use 
> gcc-3.4.1-4mdk on Mandrake 10.1-64.
> How can I tell ./configure to compile as a x86_32 program on a 64 bits 
> machine ?
> _______________________________________________
> Qemu-devel mailing list
> address@hidden
> http://lists.nongnu.org/mailman/listinfo/qemu-devel

Disclaimer: The following worked for me Fedora Core 3 x86_64 - I don't
use Mandrake, and this solution may not work for you.

$ linux32 /bin/bash

This should make sure that your 'arch' is recognized as i686 instead of

$ CC="gcc -m32" LD="ld -m32" ./configure <extra-options-that-you-want>

Should set you up for compiling and linking 32-bit binaries.

$ make


Bob Deblier

reply via email to

[Prev in Thread] Current Thread [Next in Thread]