[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] qemu problem (you might be my last resort)

From: Jim C. Brown
Subject: Re: [Qemu-devel] qemu problem (you might be my last resort)
Date: Sun, 20 Mar 2005 19:57:42 -0500
User-agent: Mutt/1.4i

On Sun, Mar 20, 2005 at 09:49:34PM +0100, Robin Pfeifer wrote:
> >You mean u get the new X window titled "QEMU", which shows the guest OS 
> >booting,
> >and once the booting is done the guest OS is actually usuable (at least as
> >usuable as it would be if it was botted on a real computer)?
> Not quite. The first disk I tried was a very old DOS 6.0 I still have 
> lying around (I haven't got that many boot floppies anymore), and it 
> didn't quite finish booting - but I thought, maybe the disk is broken. 
> But I have also tried a Linux-based floppy which I have used as a boot 
> disk previously, and downloaded bootE and tried that, too - I'm finding 
> the kernel simply stops booting after a while. It does boot normally 
> during a real boot process.

Ok, so where does it stop booting? At what point does it freeze?

> But that still goes much farther than booting a cdrom image, as I 
> actually get to see the BIOS being set up and the kernel being started. 
> With a cdrom or image of such I immediately get a blank screen.

> >Here are a few more tests to try out:
> >
> >If you boot from a hard disk, no floppy or cdrom image given, does it work?
> Hm, would that be something like 'qemu -hda /dev/hda1 -snapshot -m 256'? 

Probably more like 'qemu -hda /dev/hdb -snapshot -m 256' (/dev/hda1 wouldnt
work unless you have a partition table on it _or_ you set it up so that the OS
can boot off of a raw hard disk w/o a partition table (afaik this isnt even
possible w/ win2k). If you have no idea what I just said, just take my word
that /dev/hda1 wouldn't work).

> That gives me the same error as booting from a cdrom. hda1 should be a 
> Win2000 system. When I enter a disk which is present but not bootable 
> (for instance sda1, where my Linux system is located, which I boot from 
> a floppy), the BIOS does appear until the obvious error message turns up 
> that there is no system on the disk. The qemu window remains responsive 
> and can be closed - the crashed window I get when trying to boot 
> something bootable cannot be closed except with xkill or Ctrl + c in the 
> terminal from which I started it.

Of course if you did use /dev/hda1 then you should have gotten 'not bootable'
error too. I'd recommend downloading the freedos 10Meg disk image, or maybe
the dlxlinux disk image that comes with bochs, and see if those hard disk
images boot.

> It appears that qemu becomes weird when it encounters a boot block - 
> though that doesn't explain why it does boot floppies at least up to a 
> point.

3 ways a cdrom can be made to look bootable:

1) a part of the cdrom looks like a floppy disk, and the bios uses this to boot

2) a part of the cdrom looks like a tiny hard disd, and the bios uses this

3) the bios loads the boot program directly from the cdrom w/o any emulation

1) is the most common, and odds are good that your bootable cdroms use the
floppy disk method. (The reason this is done is for backwards compatibility
I guess.) So my guess is that it isn't the boot sector, but IDE (if I had
to guess).

Perhaps the boot disks freeze up at the point that they try to access the cdrom?
Or at least detect it?

> >I'm trying to see if this problem is caused by trying to access the cdrom,
> >or if it only comes up when you try to boot from it. (BTW how many 
> >different
> >cdroms/cdrom images have you tested?)
> I have tested a couple of live CDs, Knoppix, Kanotix, RescueCD, Insert, 
> SuSE... all of which boot correctly the normal way. the Knoppix and 
> Insert CDs I actually booted a couple of times successfully with qemu, 
> too, before qemu began to fail me.

These all real CDs, or have you tested images as well?

Infinite complexity begets infinite beauty.
Infinite precision begets infinite perfection.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]