[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] MS-DOS Network Client

From: Jim C. Brown
Subject: Re: [Qemu-devel] MS-DOS Network Client
Date: Mon, 21 Mar 2005 15:22:26 -0500
User-agent: Mutt/1.4i

On Mon, Mar 21, 2005 at 08:34:19PM +0100, Andreas Krause wrote:
> I finally ran out of ideas.
> All I wanted to do is:
> Host OS: XP
> Guest OS: DOS
> boot some DOS
> setup Network (Lan Manager with TCP/IP transport)
> login to some Windows NT4.0 domain
> mount a share
> run an install.bat located on this share
> I tried almost every combination of the following variables:
> NE2000/ISA, RTL8029/PCI
> user-net, tap
> different BIOSses
> different qemu-releases (0.6.0, 0.6.1, daily builds)
> different network stacks (MS Network Client, WatTCP)
> DHCP, fixed IP (10.0.2.x in user mode, 192.168.0.x in tap mode)
> Completely no success.

I use Linux as the host OS, and I also have never been able to get MSDOS to
use the network in qemu.

I just tried and same problem as last - hardware seems to be detected and work,
but no packets can be seen.

I use qemu's own BIOS and have had this problem since 0.5.5

> In other OSs than DOS (Knoppix, NT4.0) networking works perfectly in almost 
> every combination without any effort.
> In DOS, I could load both, ne2000.dos and pcind.dos, by using a current bochs 
> BIOS - but not a single packet seems to be transmitted in any configuration. 
> In Linux and NT4.0 networking work's perfectly with the same parameters.
> Any clue? Did anyone run MS-DOS LAN Manager ind qemu successfully? Please, if 
> any of the developers could try this combination and anlyaze somehow deeper 
> than I am able to do? All I can do is try & error all day...
> Thanks in advance
> CU - nak
> _______________________________________________
> Qemu-devel mailing list
> address@hidden
> http://lists.nongnu.org/mailman/listinfo/qemu-devel

Infinite complexity begets infinite beauty.
Infinite precision begets infinite perfection.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]