[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] qemu problem (you might be my last resort)

From: Robin Pfeifer
Subject: Re: [Qemu-devel] qemu problem (you might be my last resort)
Date: Mon, 21 Mar 2005 22:02:30 +0100
User-agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.7.5) Gecko/20041220

Jim C. Brown schrieb:
On Mon, Mar 21, 2005 at 06:37:31PM +0100, Robin Pfeifer wrote:
Not quite. The first disk I tried was a very old DOS 6.0 I still have lying around (I haven't got that many boot floppies anymore), and it didn't quite finish booting - but I thought, maybe the disk is broken. But I have also tried a Linux-based floppy which I have used as a boot disk previously, and downloaded bootE and tried that, too - I'm finding the kernel simply stops booting after a while. It does boot normally during a real boot process.
Ok, so where does it stop booting? At what point does it freeze?
The BootE floppy stops while the display says 'Loading' with a row of dots. But when the emulation window is started, it always displays 'qemu stopped' for a short moment, after which the 'stopped' disappears and the BIOS messages appear in the window. This short moment is what the other attempts do not get over. The floppy emulation passes that.

I assume Linux boot floppy stops at the same point?

More or less. It doesn't say 'Loading' but 'vmlinuz', but it stops after a number of dots.

I have just deleted all qemu files again and installed the current dad-answers snapshot version, first with kqemu, which still doesn't work, then without. The problem persists. However, I'm not sure qemu actually freezes, as I've thought of looking at it with 'top' - qemu is taking up better than 90% of CPU while running, so it seems to be doing something. I just can't find out what...

/dev/hdb doesn't work, I have no second IDE harddisk - I've got one IDE and one SCSI harddisk. /dev/hda results in the 'qemu stopped' error, hdb of course in a 'could not open hard disk image'.

I have downloaded the Freedos image and started it with

qemu -hda /path/to/freedos.img -snapshot

Same error: qemu stopped.

I can't reproduce this error. Using latest CVS, 'qemu -m 350' works perfectly
fine for me. In fact it works fine for qemu 0.5.5 as well.
Only difference is that I use kerenl 2.4.26 and I have the rtc set to 100hz
instead of 1024hz. I also have never installed or used kqemu.

Can you run gdb on it and figure out where in the code it freezes?

I have just tried that, but I don't know the first thing about gdb. I have started qemu with -S to make it stop soon enough, then had gdb attach to its process number - that results in qemu not responding to anything anymore. Same if I use -s to have qemu wait for gdb. I have no idea how to tell gdb to start qemu as a parameter, it does not work with including qemu's parameters in '' or "". I think it would perhaps be best if you just told me what to do, I'm just a little user out of his depth... :)

I think I'll let qemu run overnight to see whether it might not actually be doing something after all...


reply via email to

[Prev in Thread] Current Thread [Next in Thread]