[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Issues on Mac OS X (host) with qemu-system-ppc (guest)

From: U n d e r a c h i e v e r
Subject: [Qemu-devel] Issues on Mac OS X (host) with qemu-system-ppc (guest)
Date: Sat, 26 Mar 2005 22:34:27 +0000
User-agent: Mozilla Thunderbird 1.0 (Macintosh/20041206)

Hi all

I've been trying to get a recent (CVS from yesterday) build of qmeu on Mac OS X to run a recent-ish linux distro or bsd release for powerpc.

The configure/make/make install goes well, but the binary created won't
boot debian sarge network installer iso CD image nor ubuntu nor openbsd. An example of the problem is shown at the end of this message.

Anyway, I noticed some patches here
which it is claimed will get Debian Sarge booting on qemu-system-ppc. So tried them on yesterday's CVS download of the source. Unfortunately, the patch for op_helper.c fails completely, although the others seem to apply OK. If you ignore this and plough on with a build, the compile fails.

I then tried the patch against the 0.6.1 tarball of the source. All the patches in the diff failed *except* the ob_helper.c.

So I copied the patched ob_helper.c from the tarball to the CVS sources. configure went OK but make failed.

It was asking too much, really, with my extremely sketchy knowledge of C to get that working. Hence, my problem remains, I can't seem to boot any ppc cdrom from qemu-system-ppc. here's the error. Any ideas on how/if I can fix this?:-

$ /usr/local/bin/qemu-system-ppc -hda ./Documents/Qemu\ PC\
List/1.5Ghdd.img -cdrom ./Desktop/sarge-powerpc-netinst.iso -boot d
-nographic -user-net
(qemu) PPC Open Hack'Ware BIOS for qemu version 0.3.2
Build 2005-03-04 08:04:35
Copyright 2003-2004 Jocelyn Mayer

Memory size: 144 MB.
Booting from device d
Probing PCI devices
Found new host bridge 'pci' 'AAPL,UniNorth' 'uni-north'...
register 'pci' 'pci' 'uni-north' 'AAPL,UniNorth' 0xf2000000 in
'device-tree' 0xffffffff
Done 0581dd24 0581f7c4
Check PCI bridges
Check PCI devices
Found PCI device 1234:1111 0-96 3 0
=> 'Qemu VGA' 'display' 'Qemu VGA' 'VGA' (05809558)
register 'Qemu VGA' 'display' 'VGA' 'Qemu VGA' 0x0000000c in 'pci'
Done 0581f7c4 0581fdb4
Map PCI device 0:96 0 to 80000008 00400000 (memory)
Set VGA to 80000000
Set display 'Qemu VGA' path to '/address@hidden/Qemu address@hidden'
Found PCI device 10ec:8029 0-104 2 0
=> 'NE2000' 'network' 'NE2000 PCI' '<null>' (00000000)
register 'NE2000' 'network' '<null>' 'NE2000 PCI' 0x0000000d in 'pci'
Done 0581f7c4 05820404
MAP PCI device 0:104 to IRQ 9
Map PCI device 0:104 0 to 00001001 00000100 (I/O)
Found PCI device 106b:22 0-112 255 0
=> 'mac-io' 'mac-io' 'AAPL,Keylargo' 'Keylargo' (05809610)
register 'mac-io' 'mac-io' 'Keylargo' 'AAPL,Keylargo' 0x0000000e in
'pci' 0xf2000000
Done 0581f7c4 058207d4
MAP PCI device 0:112 to IRQ 10
Map PCI device 0:112 0 to 80400000 00080000 (memory)
PCI probe done (0581f764)
ide0: drive 0: Hard Disk
ide0: drive 1: none
ide1: drive 0: CD-ROM
Found Apple partition map...
Not a bootable partition
HFS volume
HFS ERROR in hfs_treat_boot_file: XML error: unknown Forth script: 633e4c9c

" screen" output
load-base release-load-area
boot cd:,\install\yaboot

Partition: 2 Debian testing ppc Bin-1 st 00000010 size 00060fc8
ide1: drive 1: none
Load raw file into memory at 05900000 4096

Now boot it... (05902aa0)

stack: 05ffff70 malloc_base: 05902aa0 0x05800000 0x06000000
invalid/unsupported opcode: 13 - 05 - 18 (4f543e0a) 0x05900008 1

reply via email to

[Prev in Thread] Current Thread [Next in Thread]