[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] cvs build broken?

From: jeebs
Subject: [Qemu-devel] cvs build broken?
Date: Fri, 10 Jun 2005 18:06:31 -0500

I've been following the qemu-user's forum thread with CoMiKe describing how 
to build qemu under windows with MingW.  For those of us who don't use 
Linux, the regular instructions are about as clear as mud.

CoMiKe's instructions are pretty good, and as soon as a few more people give 
it a try and work out any more bugs, I hope the directions get added to the 
official qemu docs.

It looks like there's a compile error for Mingw for the current cvs.

Here's the relevant section.

gcc -Wall -O2 -g -fno-strict-aliasing -fomit-frame-pointer -I. 
 -I/home/Admin/qemu/fpu -I/home/Admin/qemu/slirp -c -o slirp/udp.o 
H:/MSys/home/Admin/qemu/slirp/udp.c: In function `udp_emu':
H:/MSys/home/Admin/qemu/slirp/udp.c:428: warning: no semicolon at end of 
struct or union
H:/MSys/home/Admin/qemu/slirp/udp.c:428: error: syntax error before '.' 
H:/MSys/home/Admin/qemu/slirp/udp.c:405: warning: unused variable `addrlen'
H:/MSys/home/Admin/qemu/slirp/udp.c:429: warning: unused variable `seqn'
H:/MSys/home/Admin/qemu/slirp/udp.c:430: warning: unused variable `message'
H:/MSys/home/Admin/qemu/slirp/udp.c:431: warning: unused variable 
H:/MSys/home/Admin/qemu/slirp/udp.c:432: warning: unused variable `pkt_len'
H:/MSys/home/Admin/qemu/slirp/udp.c: At top level:
H:/MSys/home/Admin/qemu/slirp/udp.c:433: warning: type defaults to `int' in 
declaration of `cu_head'
H:/MSys/home/Admin/qemu/slirp/udp.c:433: warning: data definition has no 
type or storage class
H:/MSys/home/Admin/qemu/slirp/udp.c:435: error: syntax error before "switch"
H:/MSys/home/Admin/qemu/slirp/udp.c:618: warning: type defaults to `int' in 
declaration of `cu_head'
H:/MSys/home/Admin/qemu/slirp/udp.c:618: error: conflicting types for 
H:/MSys/home/Admin/qemu/slirp/udp.c:433: error: previous declaration of 
'cu_head' was here
H:/MSys/home/Admin/qemu/slirp/udp.c:618: error: `m' undeclared here (not in 
a function)
H:/MSys/home/Admin/qemu/slirp/udp.c:618: warning: data definition has no 
type or storage class
H:/MSys/home/Admin/qemu/slirp/udp.c:619: error: syntax error before '->' 
make[1]: *** [slirp/udp.o] Error 1
make[1]: Leaving directory `/home/Admin/qemu

Plus an assortment of warnings.  I would have expected qemu to compile 

I tried the cvs version over the past several days, and they fail.  The 
official 0.70 build compiles, though.

At first I thought I was doing something wrong, since I'm not familiar with 
building it.  Especially since I would have expected somebody to have 
complained by now.

And I've even tried two versions of Mingw/GCC.

But the error is pretty consistant, and the official 0.70 build off qemu.org 
compiles and runs.

So I figured I should report it, in case it's a Windows specific problem. 
We all know how many windows users there are in here....  And even fewer 
trying to build it themselves.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]