[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Timing problems

From: Alexander Toresson
Subject: Re: [Qemu-devel] Timing problems
Date: Wed, 29 Jun 2005 16:48:32 +0200

Oliver Gerlich wrote:
> Alexander Toresson wrote:
> > I'm running windows 2000 in qemu 0.7.0 with kqemu 0.6.2-1 on i386
> > debian linux. First thing I tried to do was to run a benchmark program
> > (qemu w/o kqemu vs qemu w/ kqemu). I got strange results, and I also
> > noted that timing didn't seem to be that good, so I re-tried to run
> > the benchmark program, but with the date & clock settings window in
> > the background. This is the result: The more cpu that is used in the
> > virtual cpu, the faster time flies by. For example, when it's nearly
> > idle, time is too slow. If it goes from idle to 100% cpu-use, time
> > flies by at 5x the speed it should. This is true both when I use kqemu
> > and when I don't. This cpu is capable of speedstep, but I have
> > disabled it while doing this test. I think I would get even more weird
> > results if I enabled it.
> > This makes it impossible to run a benchmark and get any useful results
> > out of it. Also, trying to run a game on qemu would be a disaster.
> Not necessarily, Age of Empires 2 runs quite well under Qemu + Win98SE
> (on an Athlon 2600+, host: Debian Linux, kernel 2.6.9).
> > However, running normal programs aren't any problem. Except that I
> > have to be very quick when changing resolution in w2k (it should wait
> > 15s, now time flies away and those 15 becomes 2s :)).
> >
> > Before compiling qemu 0.7.0 with kqemu 0.6.2-1, I ran qemu
> > 0.6.something, taken from the debian testing repository, and it had
> > the same problem.
> >
> > Regards, Alexander Toresson
> >
> > PS. I'm susprised nobody has seen this problem before. Is it just me
> > who experience it?
> Although I use Visual Studio 5 and Age of Empires 2 inside Qemu (with
> Win98SE and Win2k), I never noticed such problems, and the Windows clock
> always seemed quite right (and VC++ stresses the CPU quite a lot!). But
> admittedly I never ran benchmarks or had a closer look at the guest
> system time.

Well, it happens any time I stress the cpu. Having the clock settings
window open and then double-clicking on My Documents is enough to see
the clock accelerate and then go back to normal speed.

malc wrote:
>CPU frequency scaling might be the cause. If your OS uses speedstep
>or similar tech QEMU timers will misbehave.

This was tested when speedstep was disabled, which I did by shutting
down powernowd. Then cat /proc/cpuinfo shows 1.86ghz constantly, which
is the maximum cpu frequency.

Regards, Alexander Toresson

reply via email to

[Prev in Thread] Current Thread [Next in Thread]