[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] qemu-system-ppc: blank screen

From: Tilman Sauerbeck
Subject: Re: [Qemu-devel] qemu-system-ppc: blank screen
Date: Thu, 30 Jun 2005 20:37:36 +0200
User-agent: mutt-ng 1.5.9i (Linux)

Tero Kaarlela <address@hidden> [2005-06-30 19:45]:
> >I'm trying to run qemu-system-ppc on a x86 box (Linux 2.6.12, gcc
> >3.4.3), but the SDL window that qemu opens just stays black, there's no
> >output at all (nothing on stdout either).
> >For example, I tried to run qemu-system-ppc with the linux-ppc image
> >from freeoszoo.org.
> >I launched qemu like this:
> >qemu-system-ppc -prep -kernel zImage.prep linux-ppc.img  
> If you are using current CVS try qemu-system-ppc -M prep -kernel zImage.prep 
> linux-ppc.img
> BTW in order to get that image to boot you need patch for ide.c that Jim C 
> Brown posted here few days ago.

Sweet, with that command line switch and Jim's patch, qemu (cvs HEAD) will
start up and boot linux-ppc.img just fine :)

Next, I tried to install a real Linux distro (CRUX PPC,

I created a disk image (crux-ppc-2.0.img) and started qemu like this:

qemu-system-ppc -M prep -kernel zImage.prep -cdrom crux-ppc-2.0.iso
-boot d -hda crux-ppc-2.0.img 

However, it doesn't boot correctly:

Any idea how to fix this?


learn to quote: http://www.netmeister.org/news/learn2quote.html

reply via email to

[Prev in Thread] Current Thread [Next in Thread]