[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Keyboard issues, native DOS mode

From: David Burrows
Subject: [Qemu-devel] Keyboard issues, native DOS mode
Date: Tue, 14 Mar 2006 19:40:58 +1100 (EST)

Hi all,

Some of you will already be aware of this issue, as it has been discussed on #qemu on freenode (irc). This issue is as follows.


This particular application, which is used to tune the aftermarket fuel injection computer in my car, has a problem when running in native
DOS mode, where two keypresses are received, instead of just the one that
was actually pressed.  In particular I'm referring to the cursor keys.

Interestingly enough, this behaviour is not exhibited when the program is run from within either win98se or win2k. However, as this program needs direct access to the serial port, this is not a desirable workaround.

You can test this by selecting offline mode when starting the application. Press ALT F to get to the file menu, and try navigating around with the cursor keys.

Apologies that this issue has already been posted in the forums under the Linux section, however as this is of a more technical nature I thought it would be best directed towards the developer's list.

It might be of note that I'm using a debian sid system, but I've also tried it on Ubuntu Breezy, and several others have reproduced the same result.


David B.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]