[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Qemu failures: x86_64 host / x86_64 guest

From: Thibaut LAURENT
Subject: [Qemu-devel] Qemu failures: x86_64 host / x86_64 guest
Date: Thu, 30 Mar 2006 03:20:50 +0200
User-agent: KMail/1.8.2


still no luck with x86_64 on last night CVS build...

* CentOS 3.6 x86_64:
   - UP won't boot with or without kqemu. Log file is attached.

  - Booting with "-kernel-kqemu" is even worse: the guest kernel won't start
at all (at least it does not print anything).

   - Booting with "-smp 2" makes it a bit further: the kernel fully boots but
the system crashes while starting Anaconda. System output in attachment.

In all cases qemu gets stuck eating 100% CPU.

* CentOS 4.2 x86_64:
  - UP does run without kqemu and with user code virtualization.  Booting
 with "-smp 2" also works.

  - However, running with "-kernel-kqemu" does not work: the kernel won't
 boot and it makes qemu crash. Log files are attached (guest output and

The good news is that i386 versions for both distros do run smoothly :-)

Host system is an Athlon 64 running a Mandriva 2006.0 with a plain kernel.org
2.6.15-4 kernel. Kqemu is 1.3.0pre5. Qemu was compiled with gcc 3.3.6-2mdk
and the host kernel with gcc 4.0.2-1mdk.
I tried several values for '-m' (128,160,192,224) with the same results.

Fabrice, do you need any more information in order to help you debug this ?


Attachment: CentOS-3.6-x86_64_no-kqemu.txt
Description: Text document

Attachment: CentOS-3.6-x86_64_smp_2.txt
Description: Text document

Attachment: CentOS-4.2-x86_64_kernel-kqemu.txt
Description: Text document

Attachment: CentOS-4.2-x86_64_kernel-kqemu_qemu-crash.txt
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]