[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Clock runs at double speed in guest

From: Thomas Tuttle
Subject: [Qemu-devel] Clock runs at double speed in guest
Date: Wed, 28 Mar 2007 20:54:32 -0400
User-agent: Mutt/1.5.13 (2006-08-11)


I have a 64-bit dual-core (Core 2 Duo) laptop, and I'm trying to install
Gentoo AMD64 on a Qemu virtual machine.

The system clock runs at double speed.  If I run `date' in a tight loop,
I can see it ticking off two seconds for every one second of real time.
The hardware clock does not run at double speed; if I run `hwclock
--hctosys', the system clock jumps back to the right time.

I have tried:

1) Setting the host's RTC's max-user-freq to 1024
2) Setting the guest's RTC's max-user-freq to 1024, just for good measure
3) Running the host with the CPU frequency locked to the minimum (1 GHz)
4) Running the host with the CPU frequency locked to the maximum (2 GHz)

This problem does not occur if:

1) The guest is booted with the kernel parameter "nolapic"
2) The guest is a 32-bit kernel
3) I manually modify hw/mc146818rtc.c to send interrupts half as

I'd really like to get this fixed, because it's the only barrier to me
being able to use Qemu (and KVM) for arch testing Gentoo.

If there's any more information I can provide (if you need access to the
machine, it could be arranged), please don't hesitate to ask.

I am not subscribed to qemu-devel, so please CC me on replies.


Thomas Tuttle

Attachment: pgpBVFNQuN4Fb.pgp
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]