[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Single stepping for PPC broken?

From: Marius Groeger
Subject: [Qemu-devel] Single stepping for PPC broken?
Date: Wed, 9 Jan 2008 08:59:35 +0100 (CET)

Hello all,

I'm having problems with qemu's (-M prep, -cpu 604) handling of the 
MSR_SE bit. My gdbstub can successfully step along regular code, but 
qemu chokes when stepping over a branch instruction like "blr". 
(Needless to say, that same gdbstub works fine on real hardware). I 
tried older versions of qemu and found that the code base 8 months ago 
worked fine.

I'd like to try this with Linux and gdbserver (or a native gdb) but I 
don't have any boot images handy and oszoo.org seems to be down right 

Any ideas? Did perhaps the PPC440 additions add some regression here?
Can someone try booting Linux on qemu-system-ppc and try 

(I haven't been following this list lately, so please bear with me if 
I missed something critical. I've searched the archives, of course, 
but to no avail.)

Regards and TIA,

Marius Groeger <address@hidden>
SYSGO AG                      Embedded and Real-Time Software
Voice: +49 6136 9948 0                  FAX: +49 6136 9948 10
www.sysgo.com | www.elinos.com | www.osek.de | www.pikeos.com

reply via email to

[Prev in Thread] Current Thread [Next in Thread]