[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Linux kernel image for Emulator - Regd.

From: Sudheer Papothi
Subject: [Qemu-devel] Linux kernel image for Emulator - Regd.
Date: Tue, 24 Jun 2008 15:02:15 +0530
User-agent: Thunderbird (X11/20080505)


I am newbie to l inux porting. I was trying to port linux on a new ARM platform.

Before doing that I would like to debug the same using ARM emulator.

So, I tried the arm-linux image (cpu type: arm1136) that I built, on qemu. But i am getting the following error.

$ qemu-system-arm -cpu arm1136 -kernel zImage -initrd arm_root.img -nographic -append "console=ttyAMA0"

qemu: fatal: Bad mode 0

R00=0018fc7c R01=00000000 R02=e3a131a4 R03=00000000
R04=000131a4 R05=0018fc7c R06=e18c8da9 R07=0018fcf4
R08=00008000 R09=0000000c R10=0000000d R11=00198fc4
R12=00000000 R13=00198fa8 R14=00010a30 R15=00008000
PSR=000001d3 ---- A svc32
s00=00000000(       0) s01=00000000(       0) d00=0000000000000000(       0)
s02=00000000(       0) s03=00000000(       0) d01=0000000000000000(       0)
s04=00000000(       0) s05=00000000(       0) d02=0000000000000000(       0)
s06=00000000(       0) s07=00000000(       0) d03=0000000000000000(       0)
s08=00000000(       0) s09=00000000(       0) d04=0000000000000000(       0)
s10=00000000(       0) s11=00000000(       0) d05=0000000000000000(       0)
s12=00000000(       0) s13=00000000(       0) d06=0000000000000000(       0)
s14=00000000(       0) s15=00000000(       0) d07=0000000000000000(       0)
s16=00000000(       0) s17=00000000(       0) d08=0000000000000000(       0)
s18=00000000(       0) s19=00000000(       0) d09=0000000000000000(       0)
s20=00000000(       0) s21=00000000(       0) d10=0000000000000000(       0)
s22=00000000(       0) s23=00000000(       0) d11=0000000000000000(       0)
s24=00000000(       0) s25=00000000(       0) d12=0000000000000000(       0)
s26=00000000(       0) s27=00000000(       0) d13=0000000000000000(       0)
s28=00000000(       0) s29=00000000(       0) d14=0000000000000000(       0)
s30=00000000(       0) s31=00000000(       0) d15=0000000000000000(       0)
FPSCR: 00000000

So, I tried the linux image ( cpu: arm1136 ) which is already working on our platform, on qemu. Here, even in this case, the above error is reproduced.

Can anyone please let me know what changes are required in linux kernel to run it on emulator (i.e., qemu).

It would be great if some one points to the documentation of linux kernel compilation for emultors (if anything specifically required) other than normal compilation.

I tried the arm test binary present in Qemu website and it is working fine.

Thanks & Regards

reply via email to

[Prev in Thread] Current Thread [Next in Thread]