[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Bug: SCSI/VirtIO: VM unable to reboot from non-IDE controll

From: Alexey Eremenko
Subject: [Qemu-devel] Bug: SCSI/VirtIO: VM unable to reboot from non-IDE controller
Date: Mon, 20 Apr 2009 12:53:10 +0300

Hi All !

Most Linux VMs (Ubuntu and Red Hat-based systems -- RHEL, Fedora) have
failed during automated tests
on SCSI and VirtIO disks on Qemu/KVM.
It turned out to be a problem of Qemu/KVM, where after a software reboot
(i.e. initiated by guest OS), the system is unable to boot from SCSI

To reboot successfully you need either soft reboot+IDE or Hard reboot (Qemu
cold boot)+SCSI.

The Command sent to Qemu/KVM:
/usr/local/bin/qemu-system-x86_64 -m 512 -monitor
tcp:localhost:4602,server,nowait -cdrom /isos/linux/Fedora-8-i386-DVD.iso
-drive file=/vm/fedora8-32.qcow2,if=scsi,boot=on -name fedora8-32

Host: RHEL 5/x64, KVM-85rc6. (tried both Intel and AMD)
Guests: Ubuntu-8.10, RHEL 5, Fedora 8, Fedora 9 (tried both 32 and 64-bit).

Due to lack of Qemu bugzilla -- bugs were opened on Ubuntu Launchpad
and KVM bugzilla.

-Alexey Eromenko "Technologov", 20.4.2009.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]