[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Powerpc regressions?

From: Aurelien Jarno
Subject: Re: [Qemu-devel] Powerpc regressions?
Date: Sat, 11 Jul 2009 01:42:52 +0200
User-agent: Mutt/1.5.18 (2008-05-17)

On Tue, Jul 07, 2009 at 05:48:02PM -0500, Rob Landley wrote:
> If you grab this tarball:
> http://impactlinux.com/fwl/downloads/binaries/system-image/system-image-powerpc.tar.bz2
> Extract it, and ./run-emulator.sh.
> This ran fine under svn 6657 (which is git 2d18e637e5ec).  The next commit 
> screwed up openbios, but 
> reverting openbios worked for a while.
> In the last couple months, two problems have cropped up:
> 1) -hda sets /dev/hdc instead of /dev/hda (which is the cdrom).

Wrong. -hda sets the first hard drive, that is on the internal PowerMAC
controller. -hdc sets the first drive of the add-on IDE card that is
used in this emulation to connect the CD-ROM, as the PowerMAC IDE
controller emulation has still some bugs.

Then the Linux kernel decide to call the cdrom hda and the hard-disk
hdc. You will get exactly the same result if you put an add-on card
on a real PowerMAC machine. If you consider that a bug, you should
report the bug to the Linux kernel.

> 2) The kernel panics running init:

This is a bug I don't reproduce with my Debian installation, but that I
am able to reproduce with your image. 

You listed commit 6657 as the culprit, but is it only for both 1) and/or
2). It would be nice to know the first bad commit for 2).

If the problem lies in OpenBIOS, then the solution is to bisect on the
OpenBIOS side.

Aurelien Jarno                          GPG: 1024D/F1BCDB73
address@hidden                 http://www.aurel32.net

reply via email to

[Prev in Thread] Current Thread [Next in Thread]