qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Re: [PATCH 30/42] Rename CPPFLAGS to CFLAGS


From: Jamie Lokier
Subject: Re: [Qemu-devel] Re: [PATCH 30/42] Rename CPPFLAGS to CFLAGS
Date: Thu, 30 Jul 2009 17:07:17 +0100
User-agent: Mutt/1.5.13 (2006-08-11)

Juan Quintela wrote:
> Paolo Bonzini <address@hidden> wrote:
> >> Ok, and what are that options?
> >> Looking at today Makefiles, the only things that I see that the user
> >> could want changing is:
> >>   -g
> >>   -O2
> >>   -fno-strict-aliasing
> >>   -fno-unit-at-a-time (ppc)
> >>   -msmall-data (alpha)
> >>   -mno-sdata (ia64)
> >>
> >> Rest of things are -I/-D stuff, that you don't want to touch from the
> >> command line at all.
> 
> Ok, with me, then the proposal is:
> rename CFLAGS into QEMU_CFLAGS
> leave in CFLAGS only "-g -O2"

A good trick is to make sure CFLAGS is included at the _end_ of
QEMU_CFLAGS (or that it comes after QEMU_FLAGS in commands), not
anywhere else:

   CFLAGS = -g -O2
   QEMU_CFLAGS = -msome-option -fno-strict-aliasing $(CFLAGS)

This way, users can override many options in QEMU_CFLAGS if they have
reason to, by supplying the opposite flag, as options coming later
usually have precedence:

   make CFLAGS='-g -O2 -fstrict-aliasing'

   ==> gcc -msome-option -fno-strict-alising -g -O2 -fstrict-aliasing <- wins

-- Jamie




reply via email to

[Prev in Thread] Current Thread [Next in Thread]