[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] bug report with kqemu on AMD 64

From: Rick Vernam
Subject: Re: [Qemu-devel] bug report with kqemu on AMD 64
Date: Tue, 17 Nov 2009 12:15:03 -0600
User-agent: KMail/1.12.2 (Linux/2.6.30-gentoo-r4; KDE/4.3.2; x86_64; ; )

On Tuesday 17 November 2009 12:11:58 am Luiz Felipe wrote:
> Hi, i tried to use kqemu in ubuntu to start Windows XP SP3. I used the
> command line: "qemu -kernel-kqemu" and the system started to run windows on
> qemu. Although, i observed the following message on my shell:
> QEMU acceleration layer not activated: Permission denied
> unknown keycodes `evdev(abnt2)_aliases(qwerty)', please report to
> address@hidden
1 - It has been stated here on the mailing list that kqemu is no longer 
supported by Qemu; by no means do I consider myself a qualified spokesman on 
the issue (I don't have hardware virtualization support, so I know where 
you're coming from).
2 - It's possible that the kqemu issue is only a permissions problem - check 
/dev/kqemu and see if you have rw permissions there (for example you might 
want to chown root:qemu /dev/kqemu and chmod 0660 /dev/kqemu ... and make sure 
you have yourself in the qemu group. maybe you'd have to create that group 
first, I really don't know).
3 - I'd guess that the unknown keycode is a separate issue...

> My computer is an AMD 64 Phenom quad-core. I had problems with virtualbox
> and kvm. The system crashed. As i've read onsome forums, it appears to be
> some incompatibility between my computr BIOS and the hardware
> virtualization since I've read that kemu emulates everything, and that's
> why it's alower than other virtualization machines.
Yes, qemu by itself emulates everything.  In the past, kqemu provided 
virtualization.  KVM now plays that role.
> May the problem experienced with kqemu is been caused by the impossibility 
of optimization using hardware?
If you can get qemu to load kqemu, many things will be virtualized resulting 
in a noticeable improvement in speed.  (ie, check /dev/kqemu file permissions)

Have you tried using Virtualbox with hardware virtualization (ie VT-x/AMD-V) 
turned off? 

> Thank's.
> Luiz Felipe

reply via email to

[Prev in Thread] Current Thread [Next in Thread]