[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 0/6] Fix -kernel with SeaBIOS v2

From: Alexander Graf
Subject: Re: [Qemu-devel] [PATCH 0/6] Fix -kernel with SeaBIOS v2
Date: Fri, 20 Nov 2009 12:34:29 +0100

On 20.11.2009, at 12:31, Christoph Hellwig wrote:

On Fri, Nov 20, 2009 at 11:53:41AM +0100, Alexander Graf wrote:
Works great here:

./x86_64-softmmu/qemu-system-x86_64 -nographic -kernel ../bzImage -
append console=ttyS0 -L pc-bios

Are you sure you also have the follow-up linuxboot patch applied? The
one "fixing BOCHS bios support". If it still doesn't work, make sure
booting works at all without -kernel.

Hmm. Tried without -enable-kvm and then it works, so it seems it's only
broken when using KVM support.

Works here as well:

address@hidden:~/work/qemu-late-int19/qemu> ./x86_64-softmmu/qemu-system- x86_64 -nographic -kernel ../bzImage -append console=ttyS0 -L pc-bios - enable-kvm [ 0.000000] Linux version 2.6.32-rc7 (address@hidden) (gcc version 4.3.4 (Debian 4.3.4-5) ) #448 SMP Wed Nov 18 18:01:25 CET 2009

Btw, it seems like seabios takes quite a bit longer than pc bios to load
the kernel, mostly while the gPXE line is displayed.

Yeah, I really wish we could disable gPXE for default boots. Usually nobody wants to -boot n anyways, and if they do they can specify that IMHO.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]