qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] what's on qemu tree for pci related fixes


From: Michael S. Tsirkin
Subject: [Qemu-devel] what's on qemu tree for pci related fixes
Date: Mon, 30 Nov 2009 12:48:19 +0200
User-agent: Mutt/1.5.19 (2009-01-05)

Here's the list of patches on my pci fixes tree:
git://git.kernel.org/pub/scm/linux/kernel/git/mst/qemu.git pci
I have rebased this tree to latest master and rearranged the patches in
the order of their being ready for upstream.  The tree is currently on
top of qemu master: I would base it on staging tree, but that is
constantly rebased, is it not?

I have slightly tweaked commit log comments on a couple of patches,
fixing typos, and adding acks. Not sure it's worth the noise to repost
on list just for this.  Anthony, can you just take patches from the
tree so that comments look nicer?

Here are the pci fixes I know of that haven't been applied on staging
already.  All, any more comments on any of them?
If yes, please reply on the original patch, not here.

        pci: move apb specific stuff to apb_pci.c
        configure: use correct cflags in compiler checks

The above are in staging now.

        pci: fix pci_info_device().
        pci: move pci_data_{read, write}() declaration from pci.h to pci_host.h
        pci: simplify (pci_/pcie_mmcfg_)data_read()
        pci: remove pci_addr_to_config() by open code
        pci: rename (pci_/pcie_mmcfg_)addr_to_dev
        pci: shorten pci_host_{conf, data}_register_xxx function a bit.
        pci: remove pci_sub_bus() by open coding.
        pci: s/pci_find_host_bus/pci_find_root_bus/g
        pci_host: remove unnecessary & 0xff.
        pci: kill unnecessary included in pci.c
        pci: clean up of pci_init_wmask().
        pci: remove some unnecessary comment in pci.h
        pci: move typedef, PCIHostState, PCIExpressHost to qemu-common.h.
        pci: remove unused constants.
        pci: clean up of pci_update_mappings()
        pci: split up up pci_update mappings
        pci: remove magic number, 256 in pci.c
        pci: fix pci_config_get_io_base().
        pci: pci bridge related clean up.
        pci: convert goto into scope in bridge_filter

The above are minor cleanups, they run fine for me, look very safe, have
at least one ack, and were out for more than 2 weeks now. Time to apply,
IMO.

        msix: add helper to mark all msix entries
        virtio: do not reset msix state on soft reset
        msix: fix mask bit state after reset
        msix: fix reset value for enable bit
        msix: clear pending bit of an unused vector

The above all look pretty obvious, safe, and fix crashes reported with
windows guests.  I think they are needed on stable-0.11 as well.
Out only about 1 week though ... more comments?

        msix: macro rename for function mask support
        msix: function mask support
        pci: prepare irq code for interrupt state
        pci: interrupt status bit implementation
        pci: interrupt disable bit support

These have been out less than 1 week, and they aren't trivial. We need
them for 0.12 so that WHQL can pass there, but maybe not for 0.11.
No known issues/unaddressed comments though.

-- 
MST




reply via email to

[Prev in Thread] Current Thread [Next in Thread]