qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PULL] master: pci fixes and cleanups


From: Michael S. Tsirkin
Subject: [Qemu-devel] [PULL] master: pci fixes and cleanups
Date: Tue, 15 Dec 2009 14:05:12 +0200
User-agent: Mutt/1.5.19 (2009-01-05)

Please pull the following into master branch.
Pull request for stable-0.12 will follow.
There's an important bugfix, the rest are
trivial. Have not been out a lot of time,
but keeping them out of master adds conflicts.


The following changes since commit d9a50a366f2178a4ddaada87bcf67764c9d0af87:
  Richard Henderson (1):
        target-alpha: Fix double log_cpu_state.

are available in the git repository at:

  git://git.kernel.org/pub/scm/linux/kernel/git/mst/qemu.git for_anthony

Isaku Yamahata (4):
      pci: remove PCIBus::config_reg.
      pci: s/PCI_SUBVENDOR_ID/PCI_SUBSYSTEM_VENDOR_ID/g
      pci: import Linux pci_regs.h
      pci: use pci_regs.h

Michael S. Tsirkin (18):
      e1000: fix init values for command register
      e1000: switch to symbolic names for pci registers
      ne2000: switch to symbolic names for pci registers
      rtl: switch to symbolic names for pci registers
      pcnet: switch to symbolic names for pci registers
      pci: add more status bits
      eepro100: symbolic names for pci registers
      piix: symbolic constants
      cmd646: symbolic names for pci registers
      vmware_vga: symbolic names for pci registers
      lsi: symbolic names for pci registers
      pci: add another devsel macro
      es1370: symbolic names for pci registers
      wdt_i6300esb: symbolic names for pci registers
      ac97: symbolic names for pci registers
      usb-uhci: symbolic names for pci registers
      usb-ohci: symbolic names for pci registers
      pci: remove unused macro

 hw/ac97.c         |   57 +++--
 hw/e1000.c        |   12 +-
 hw/eepro100.c     |   49 +++--
 hw/es1370.c       |   29 ++--
 hw/ide/cmd646.c   |    7 +-
 hw/ide/piix.c     |   13 +-
 hw/lsi53c895a.c   |   10 +-
 hw/ne2000.c       |    3 +-
 hw/pci.c          |    3 +-
 hw/pci.h          |   74 +------
 hw/pci_regs.h     |  665 +++++++++++++++++++++++++++++++++++++++++++++++++++++
 hw/pcnet.c        |   26 ++-
 hw/rtl8139.c      |   16 +-
 hw/usb-ohci.c     |    6 +-
 hw/usb-uhci.c     |    7 +-
 hw/vmware_vga.c   |   20 +-
 hw/wdt_i6300esb.c |    2 +-
 17 files changed, 821 insertions(+), 178 deletions(-)
 create mode 100644 hw/pci_regs.h




reply via email to

[Prev in Thread] Current Thread [Next in Thread]