[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [RFC] Bug Day - June 1st, 2010

From: Michael Tokarev
Subject: Re: [Qemu-devel] [RFC] Bug Day - June 1st, 2010
Date: Fri, 21 May 2010 01:32:21 +0400
User-agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv: Gecko/20100411 Icedove/3.0.4

20.05.2010 11:15, Andre Przywara wrote:
Michael Tokarev wrote:
It'd be nice if we had more flexibility in defining custom machine types
so you could just do qemu -M win98.

This is wrong IMHO. win98 and winNT can run on various different
machines, including all modern ones (yes I tried the same winNT
on my Athlon X2-64, just had to switch SATA from AHCI to IDE;
win95 works too)... just not in kvm :)

Well, not really. You were lucky with your Athlon X2-64, actually it is
the last machine not triggering the bug. I tried it on a AthlonII-X4
(which has maxleaf=5 as any newer AMD machines) and it showed the same
bug. On Intel boxes this bug should trigger on every CPU starting with
some Pentium4 models, including all Core chips.
Have you tried versions with a newer service pack (SP6)?

I replied in the original discussion -- after upgrading to SP6
there's no need in ,level=1 anymore, any -cpu variant works
without crashes.  The problem is to set it up, at least for
me, since I don't have sp6 integrated into setup.  Well, I
don't use winNT to start with, actually, so for me it's not
a problem at all ;) -- the reason why I asked is because I
have a debian bugreport about this very issue, see
(and because I had winNT install handy)

But this is really interesting information - that winNT
fails on other CPUs too.  Thank you for that, now I can
close the debian bugreport ;)

BTW: Does anyone knows what the problem with Windows95/98 on KVM is? I
tried some tracing today, but couldn't find a hint.

Um. The bugreport(s) come as a surprize for me: I tried to
install win98 in kvm several times in the past but setup
always failed - different messages in different versions
of kvm, either "unable to emulate" or "real mode trap" or
something else, or just lockup, usually on first reboot.
So - the bugreports talks about mouse non-working, but
this means win98 itself works somehow... I dunno :)

I think these bug reports are about plain QEMU. I tried it yesterday, in
fact the mouse is non-functional. In KVM Windows95 gives me a black
screen after the welcome screen with the moving bottom row. There are
just two lines at the top: (translated from the german version)
While initializing device NTKERN:
Windows protection fault. Restart the computer.

Yeah, that's what i've seen too, it's exactly
ow it fails here with modern kvm.

KVM catched some #UDs due to ARPL from VM86 mode, but TCG got them too
and it survived. So if anyone has some more hints, I'd be grateful.

Thank you!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]