[Top][All Lists]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Qemu-devel] Re: [PATCH 1/4] block: clarify the meaning of BDRV_O_NOCACH
From: |
Stefan Hajnoczi |
Subject: |
[Qemu-devel] Re: [PATCH 1/4] block: clarify the meaning of BDRV_O_NOCACHE |
Date: |
Wed, 16 Mar 2011 09:42:37 +0000 |
On Tue, Mar 15, 2011 at 2:11 PM, Christoph Hellwig <address@hidden> wrote:
> Change BDRV_O_NOCACHE to only imply bypassing the host OS file cache,
> but no writeback semantics. All existing callers are changed to also
> specify BDRV_O_CACHE_WB to give them writeback semantics.
>
> Signed-off-by: Christoph Hellwig <address@hidden>
I think there is one hunk missing:
diff --git a/block/qcow2.c b/block/qcow2.c
index 75b8bec..db1931b 100644
--- a/block/qcow2.c
+++ b/block/qcow2.c
@@ -229,7 +229,7 @@ static int qcow2_open(BlockDriverState *bs, int flags)
}
/* alloc L2 table/refcount block cache */
- writethrough = ((flags & BDRV_O_CACHE_MASK) == 0);
+ writethrough = ((flags & (BDRV_O_CACHE_WB | BDRV_O_NO_FLUSH)) == 0);
s->l2_table_cache = qcow2_cache_create(bs, L2_CACHE_SIZE, writethrough);
s->refcount_block_cache = qcow2_cache_create(bs, REFCOUNT_CACHE_SIZE,
writethrough);
Stefan
- [Qemu-devel] [PATCH, RFC 0/4] allow guest control of the volatile write cache, Christoph Hellwig, 2011/03/15
- [Qemu-devel] [PATCH 1/4] block: clarify the meaning of BDRV_O_NOCACHE, Christoph Hellwig, 2011/03/15
- [Qemu-devel] Re: [PATCH 1/4] block: clarify the meaning of BDRV_O_NOCACHE,
Stefan Hajnoczi <=
- [Qemu-devel] Re: [PATCH 1/4] block: clarify the meaning of BDRV_O_NOCACHE, Kevin Wolf, 2011/03/16
- [Qemu-devel] Re: [PATCH 1/4] block: clarify the meaning of BDRV_O_NOCACHE, Christoph Hellwig, 2011/03/16
- [Qemu-devel] Re: [PATCH 1/4] block: clarify the meaning of BDRV_O_NOCACHE, Stefan Hajnoczi, 2011/03/16
- [Qemu-devel] Re: [PATCH 1/4] block: clarify the meaning of BDRV_O_NOCACHE, Kevin Wolf, 2011/03/17
- [Qemu-devel] Re: [PATCH 1/4] block: clarify the meaning of BDRV_O_NOCACHE, Stefan Hajnoczi, 2011/03/17
[Qemu-devel] [PATCH 2/4] block: add a helper to change writeback mode on the fly, Christoph Hellwig, 2011/03/15