[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 00/15] Convert commands to QAPI (batch 1) (v2)

From: Michael Roth
Subject: Re: [Qemu-devel] [PATCH 00/15] Convert commands to QAPI (batch 1) (v2)
Date: Wed, 07 Sep 2011 18:12:25 -0500
User-agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:6.0.2) Gecko/20110902 Thunderbird/6.0.2

On 09/07/2011 05:24 PM, Anthony Liguori wrote:
On 09/07/2011 05:04 PM, Alexander Graf wrote:

On 08.09.2011, at 00:03, Anthony Liguori wrote:

On 09/07/2011 04:56 PM, Alexander Graf wrote:

On 02.09.2011, at 19:34, Anthony Liguori wrote:

This is my attempt to jump-start the QAPI switch over. All of the
hard work
is already done in my qapi branch, we just need to start merging

To simplify the merge process, I've introduced a new mode to the
code generator
that lets us do conversions without using the new QMP server.

Once this series is merged, anything that touchs QMP (to modify a
command or
add a new command) must do it through QAPI--no exceptions.

This series also includes Dans change to the 'change' command. I'm
not thrilled
about people using this command but its better to err on the side
of caution.
It's now officially deprecated with much more robust replacement

Since v1, I've tried to address all review comments. I've also
tested the
modified commands extensively.

Just stumbled over this while trying to build. Smells like missing
Makefile dependencies (works just fine with -j1), but I figured I'd
give you a heads up on this. It's a fresh checkout with nothing done
but ./configure; make -j.

address@hidden:/dev/shm/qemu> make -j
GEN i386-softmmu/config-devices.mak
GEN arm-softmmu/config-devices.mak
GEN x86_64-softmmu/config-devices.mak
GEN cris-softmmu/config-devices.mak
GEN lm32-softmmu/config-devices.mak
GEN m68k-softmmu/config-devices.mak
GEN microblaze-softmmu/config-devices.mak
GEN microblazeel-softmmu/config-devices.mak
GEN mips-softmmu/config-devices.mak
GEN mipsel-softmmu/config-devices.mak
GEN mips64-softmmu/config-devices.mak
GEN mips64el-softmmu/config-devices.mak
GEN ppcemb-softmmu/config-devices.mak
GEN ppc-softmmu/config-devices.mak
GEN ppc64-softmmu/config-devices.mak
GEN sh4-softmmu/config-devices.mak
GEN sh4eb-softmmu/config-devices.mak
GEN sparc-softmmu/config-devices.mak
GEN sparc64-softmmu/config-devices.mak
GEN i386-linux-user/config-devices.mak
GEN s390x-softmmu/config-devices.mak
GEN x86_64-linux-user/config-devices.mak
GEN alpha-linux-user/config-devices.mak
GEN arm-linux-user/config-devices.mak
GEN armeb-linux-user/config-devices.mak
GEN cris-linux-user/config-devices.mak
GEN m68k-linux-user/config-devices.mak
GEN microblaze-linux-user/config-devices.mak
GEN microblazeel-linux-user/config-devices.mak
GEN mips-linux-user/config-devices.mak
GEN mipsel-linux-user/config-devices.mak
GEN ppc-linux-user/config-devices.mak
GEN ppc64-linux-user/config-devices.mak
GEN sh4-linux-user/config-devices.mak
GEN ppc64abi32-linux-user/config-devices.mak
GEN sh4eb-linux-user/config-devices.mak
GEN sparc64-linux-user/config-devices.mak
GEN sparc32plus-linux-user/config-devices.mak
GEN unicore32-linux-user/config-devices.mak
GEN sparc-linux-user/config-devices.mak
GEN s390x-linux-user/config-devices.mak
GEN config-all-devices.mak
GEN config-host.h
GEN trace.h
GEN qemu-options.def
GEN qapi-generated/qga-qapi-visit.h
GEN trace.c
CC trace/default.o
CC trace/control.o
GEN qemu-img-cmds.h
cc1: error: qapi-generated: No such file or directory
cc1: error: qapi-generated: No such file or directory

I've seen this before too but this is due to guest-agent, not this
patch series.

Ah, sorry, didn't track down what exactly was going wrong where and
figured since it fails on qapi, it'd be related :)

I assume the root cause is that qapi-generated is being generated by
make instead of by configure. Mike, care to throw together a quick patch

Yah, QGA's code generators create qapi-generated/, and that code doesn't execute until a dependency on GENERATED_HEADERS is met. So it seems there was a pre-existing race to begin with, which got exacerbated by e4858974ec36afd8a6b3a9e2b0ad8f357f28efc7 which is missing some deps on GENERATED_HEADERS, so it got in more ahead of the code generation scripts than we'd seen previously.

to change that? Then there's no guess work tracking down dependencies.

Sure, ill send that in a few. Looks like will still get make -j build failures from that tracing patch though so I'll look at that as well.


Anthony Liguori


reply via email to

[Prev in Thread] Current Thread [Next in Thread]