[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] unable to access the serial port on the Vm

From: bala suru
Subject: Re: [Qemu-devel] unable to access the serial port on the Vm
Date: Tue, 13 Sep 2011 11:57:39 +0530

Thanks a lot , it resolved my problem .. I could get the data inside VM .

On Tue, Sep 13, 2011 at 10:53 AM, Stefan Hajnoczi <address@hidden> wrote:
On Tue, Sep 13, 2011 at 5:59 AM, bala suru <address@hidden> wrote:
> Yes, I'm connecting a USB to serial device to the host (ubuntu 11.04) and I
> want that serial port on my VM .
> I tried the solution you have suggested but still same problem , can  not
> see the virtual serial port (ttyACM0) on VM but I could see on the HOST .
> The following is the line  I have tried .
>  RAW = [ type = "kvm",
>           data = "" type=\"dev\"><source
> path=\"/dev/ttyACM0\"/><target port=\"0\"/></serial><console type=\"pty\"
> tty=\"/dev/pts/5\"><source path=\"/dev/pts/5\"/><target
> port=\"0\"/></console></devices>" ]

Inside the guest you will see a regular serial port (/dev/ttyS0).  The
guest does not know that you're using /dev/ttyACM0 on the host, but
that should not matter.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]