[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] trace build breakage with --enable-user-pie

From: Lluís Vilanova
Subject: Re: [Qemu-devel] trace build breakage with --enable-user-pie
Date: Wed, 14 Sep 2011 23:00:49 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.3 (gnu/linux)

Richard Henderson writes:

> The build with --enable-user-pie has recently broken:
>   LINK  i386-linux-user/qemu-i386
> /usr/bin/ld: ../trace/control.o: relocation R_X86_64_32 against 
> `.rodata.str1.1' can not be used when making a shared object; recompile with 
> -fPIC
> ../trace/control.o: could not read symbols: Bad value
> collect2: ld returned 1 exit status
> make[1]: *** [qemu-i386] Error 1
> make: *** [subdir-i386-linux-user] Error 2

> I suspect, but have not proven, that edb47ec498a5c00607e8d428668d5141822a9eac 
> is the cause.

> I think we ought to be compiling these files into libuser,
> with all the CFLAGS implied by that.  Our baroque configure/makefile
> setup is currently defeating me, however.

Strange, I tried with vanilla 44520db1 and it's compiling fine...

    $ ./configure --target-list="x86_64-linux-user i386-linux-user"

A call to 'uname -a' lists my system is an amd64 (x86_64), and tried
with both gcc-4.6.1 and gcc-4.4.6 (from Debian).


 "And it's much the same thing with knowledge, for whenever you learn
 something new, the whole world becomes that much richer."
 -- The Princess of Pure Reason, as told by Norton Juster in The Phantom

reply via email to

[Prev in Thread] Current Thread [Next in Thread]