[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [Bug 818673] Re: virtio: trying to map MMIO memory

From: hkran
Subject: Re: [Qemu-devel] [Bug 818673] Re: virtio: trying to map MMIO memory
Date: Fri, 16 Sep 2011 16:52:34 +0800
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20110617 Red Hat/3.1.11-2.el6_1 Thunderbird/3.1.11

On 09/16/2011 03:37 AM, Rick Vernam wrote:
On Thursday 15 September 2011 11:23:53 Rick Vernam wrote:
On Wednesday 14 September 2011 16:30:11 Rick Vernam wrote:
On Wednesday 14 September 2011 14:42:09 vrozenfe wrote:
Thank you, Rick.

Could you help me to narrow this problem down?

As I see, you have three virtio drivers installed on your system -
block, net, and virtio serial. Technically, anyone of them can create
"trying to map MMIO memory" problem. The best way to find a buggy
driver ( or drivers) will be to isolate one from the other. If you
can, please try running only one virtio device every time to see which
driver sends incorrect  scatter/gather list element to QEMU.
Sure, no problem.  I'll have that in the next few days.
I started qemu without any of the virt-serial stuff, specfically:
qemu-system-x86_64 -cpu host -enable-kvm -pidfile
/home/rick/qemu/hds/wxp.pid - drive
file=/home/rick/qemu/hds/wxp.raw,if=virtio,aio=native -m 1536 -name WinXP
-net nic,model=virtio -net user -localtime -usb -vga qxl -spice
port=1234,disable-ticketing -monitor stdio

It's been running for around 2 hours and no crash yet.
So without virt-serial, the machine ran until I rebooted the guest OS, then
crashed with the same error message.  Without virt-serial it seemed to be
stable so long as it was just left running.

Now I'll run it without virt-net, and let you know how that goes.


Another question. You said, the problem happens after every second or
third restart. Do you shutdown your VM,  or just restart it?
Have to shut down the VM guest so that the qemu process exits.

How does it work
after going through several hibernate/resume, and/or suspend/resume
I often will suspend with or without pausing qemu (via monitor commands
'stop' and 'cont').  I have never experienced any problem with the qemu
process that was running prior to the suspend.

Best regards,
I have tried many times with many restarts or shutdown-and-boot xp guest but failed to meet the crashing.
(I am using the virtio drivers referenced in the earlier mail list.)
my command:

/home/huikai/qemu15/bin/qemu --enable-kvm -m 768 -drive file=/home/huikai/winxp_dev.img,if=virtio -net nic,model=virtio -net user -usb -usbdevice tablet -localtime -vga qxl -device virtio-serial -chardev spicevmc,name=vdagent,id=vdagent -device virtserialport,chardev=vdagent,name=spice0 -spice port=1234,disable-ticketing -monitor telnet:localhost:12341,server,nowait

reply via email to

[Prev in Thread] Current Thread [Next in Thread]