[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [Bug 739785] Re: qemu-i386 user mode on ARMv5 host fails (b

From: Justin Shafer
Subject: [Qemu-devel] [Bug 739785] Re: qemu-i386 user mode on ARMv5 host fails (bash: fork: Invalid argument)
Date: Mon, 19 Sep 2011 09:31:59 -0000

I would like to run wine. I have compiled qemu 0.15.5 from git and I
noticed we can enable nptl without a patch. I can run an x86 nptl bash
but I havent tried to chroot. I have the posix wine running with qemu...
So i tried it with wine and I am able to get a --version out of it, but
when I actually run it, it does a fork. It will ask for library files
and I will stick them in /usr/gnemul/qemu-i386/usr/lib one at a time and
everntually it stops asking for files and just errors out.

Tried 0.9.22, 1.01 and 1.21...  Stole files from Ubuntu 5, Ubuntu 9,

address@hidden:/wine/usr/lib# wine-pthread
qemu: Unsupported syscall: 240
Usage: wine PROGRAM [ARGUMENTS...]   Run the specified program
       wine --help                   Display this help and exit
       wine --version                Output version information and exit

address@hidden:/wine/usr/lib# wine-pthread notepad.exe
wine-pthread notepad.exe
qemu: Unsupported syscall: 240
qemu: Unsupported syscall: 240
wine: fork : Invalid argument

On Posix it does an unsuportive syscall of 254 but works. I have seen it
do a 240 though, but thats when its asking for library files.. I cant
help but wonder if its needing a file, though not asking me.

You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.

  qemu-i386 user mode on ARMv5 host fails (bash: fork: Invalid argument)

Status in QEMU:

Bug description:
  Good time of day everybody,

  I have been trying to make usermode qemu on ARM with plugapps
  (archlinux) with archlinux i386 chroot to work.

  1. I installed arch linux in a virtuabox and created a chroot for it with 
mkarchroot. Transferred it to my pogo plug into /i386/
  2. I comiled qemu-i386 static and put it into /i386/usr/bin/
  ./configure --static --disable-blobs --disable-system 

  3. I also compiled linux kernel 2.6.38 with CONFIG_BINFMT_MISC=y and 
installed it.
  uname -a
  Linux Plugbox 2.6.38 #4 PREEMPT Fri Mar 18 22:19:10 CDT 2011 armv5tel 
Feroceon 88FR131 rev 1 (v5l) Marvell SheevaPlug Reference Board GNU/Linux

  4. Added the following options into /etc/rc.local
  /sbin/modprobe binfmt_misc
  /bin/mount binfmt_misc -t binfmt_misc /proc/sys/fs/binfmt_misc

  5. Also copied ld-linux.so.3 (actually ld-2.13.so because ld-
  linux.so.3 is a link to that file) from /lib/ to /i386/lib/

  6.Now i chroot into /i386 and I get this:
  address@hidden i386]# chroot .
  [II aI hnve ao address@hidden /]# pacman -Suy
  bash: fork: Invalid argument

  7.I also downloaded linux-user-test-0.3 from qemu website and ran the test:
  address@hidden linux-user-test-0.3]# make
  ../qemu-0.14.0/i386-linux-user/qemu-i386 -L ./gnemul/qemu-i386 i386/ls -l 
  BUG IN DYNAMIC LINKER ld.so: dl-version.c: 210: _dl_check_map_versions: 
Assertion `needed != ((void *)0)' failed!
  make: *** [test] Error 127

To manage notifications about this bug go to:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]