[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [Bug 818673] Re: virtio: trying to map MMIO memory

From: Rick Vernam
Subject: [Qemu-devel] [Bug 818673] Re: virtio: trying to map MMIO memory
Date: Thu, 29 Sep 2011 02:07:03 -0000

So I've built qemu with -enable-debug and tried running with an attached GDB, 
but got nothing.
I've never tried to debug Qemu before, but I know it's not quite a simple as 
debugging other apps.
I am honestly clueless about how to further debug this problem.

Should I give up on using virtio-serial for spice vdagent integration?
It seems that nobody really has any interest in this problem.

Are other people using qemu with spice (including functional guest agent 
support, copy/paste, etc)?  How?
I know hkran posted how (s)he uses qemu without hitting this bug, but when I 
use qemu in that way, I loose guest agent.

I like to fix things myself, and I hate to be asking about this when everybody 
clearly has more interesting things to do.
I just need some input so that I can have realistic expectations.


You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.

  virtio: trying to map MMIO memory

Status in QEMU:

Bug description:
  Qemu host is Core i7, running Linux.  Guest is Windows XP sp3.
  Often, qemu will crash shortly after starting (1-5 minutes) with a statement 
"qemu-system-x86_64: virtio: trying to map MMIO memory"
  This has occured with qemu-kvm 0.14, qemu-kvm 0.14.1, qemu-0.15.0-rc0 and 
qemu 0.15.0-rc1.
  Qemu is started as such:
  qemu-system-x86_64 -cpu host -enable-kvm -pidfile /home/rick/qemu/hds/wxp.pid 
-drive file=/home/rick/qemu/hds/wxp.raw,if=virtio -m 768 -name WinXP -net 
nic,model=virtio -net user -localtime -usb -vga qxl -device virtio-serial 
-chardev spicevmc,name=vdagent,id=vdagent -device 
virtserialport,chardev=vdagent,name=com.redhat.spice.0 -spice 
port=1234,disable-ticketing -daemonize -monitor 
  The WXP guest has virtio 1.1.16 drivers for net and scsi, and the most 
current spice binaries from spice-space.org.

To manage notifications about this bug go to:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]