[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [SeaBIOS] : Memory problem with Qemu/SeaBIOS

From: Kevin O'Connor
Subject: Re: [Qemu-devel] [SeaBIOS] : Memory problem with Qemu/SeaBIOS
Date: Mon, 7 May 2012 20:55:21 -0400
User-agent: Mutt/1.5.21 (2010-09-15)

On Mon, May 07, 2012 at 08:58:45AM -0700, Alain Ribière wrote:
> Hello,
> I have a memory trouble with an old DOS OS from Digital Research called 
> Concurrent DOS.
> It worked fine till Qemu v0.11.1.
> I use Qemu to make a legacy application run without any modification.
> Starting with Qemu 0.12, my legacy application has not enough memory to run.
> Actually it seems that the SeaBIOS doesn't use the same memory mapping than 
> PC-BIOS used to, causing trouble to my application.
> Is there any way to get SeaBIOS use (more or less) the same memory amount and 
> memory mapping than the older PC-BIOS ?
> I tried to recomplie SeaBIOS 1.7.0 with less options but the result is the 
> same.

When reporting an issue with SeaBIOS, please include the log obtained
when running qemu with "-chardev stdio,id=seabios -device

I took a quick look at this, and I don't think this is a memory size
issue - the screenshots actually show that running under seabios makes
more memory available (15664 vs 15648).  Instead, I'd guess concurrent
dos is not making a "banked window" that is large enough.  I don't
know why the memory segments between 0x0b00 and 0x3400 aren't being
used.  There is no legacy bios interface to reserve memory under 1meg,
so I'm sure SeaBIOS isn't doing this wrong.  Indeed, SeaBIOS is much
more careful about touching ram under 1meg than Bochs bios is.

So, I'd guess something unrelated is confusing concurrent dos and the
above is just a symptom of the problem.  Unfortunately, I don't know
of any way to track that down without source code for the image and
spending a large amount of debugging time.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]