[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Is *-bsd-user target broken?

From: Igor Mammedov
Subject: [Qemu-devel] Is *-bsd-user target broken?
Date: Tue, 26 Jun 2012 17:49:03 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20120605 Thunderbird/13.0

Hello Blue,

I've tried to test if *-bsd-user target works but so far wasn't successful so 
I've tried qemu-1.x ports on the latest freebsd/openbsd and a freshly checked 
out qemu.

If it works for you, could you tell:
  1. what flavor of bsd you use for testing
  2. what configure options are used for building *-bsd-user and maybe some 
other magic
  3. command line running emulator, for example to execute /bin/ls (may be I'm 
doing something wrong here)

Example of what I've did on FreeBSD, qemu with your recent patches and ld patch 
form qemu-devel port:

# ./configure  --enable-debug  --disable-werror --target-list=i386-bsd-user

# ./i386-bsd-user/qemu-i386 -strace -bsd FreeBSD -L / /bin/ls

After some waiting it SIGSEGVs with following trace:

0x801484e8 in g_hash_table_lookup () from /usr/local/lib/libglib-2.0.so.0
(gdb) bt
#0  0x801484e8 in g_hash_table_lookup () from /usr/local/lib/libglib-2.0.so.0
#1  0x6001788c in type_table_lookup (name=0x600c72be "i386-cpu") at 
#2  0x60017b60 in type_get_by_name (name=0x600c72be "i386-cpu") at 
#3  0x60018837 in object_dynamic_cast (obj=0x80534010, typename=0x600c72be 
"i386-cpu") at qom/object.c:435
#4  0x6001897e in object_dynamic_cast_assert (obj=0x80534010, typename=0x600c72be 
"i386-cpu") at qom/object.c:484
#5  0x60051eff in x86_cpu_realize (obj=0x80534010, errp=0x0) at 
#6  0x60053488 in cpu_x86_init (cpu_model=0x600c3711 "qemu32") at 
#7  0x60022c61 in cpu_init (cpu_model=0x600c3711 "qemu32") at cpu.h:965
#8  0x6002238e in main (argc=7, argv=0xbfbfebd4) at 


reply via email to

[Prev in Thread] Current Thread [Next in Thread]