qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PATCH 00/11] acpi_table_add() code cleanup


From: Eduardo Habkost
Subject: [Qemu-devel] [PATCH 00/11] acpi_table_add() code cleanup
Date: Wed, 27 Jun 2012 17:22:56 -0300

Hi,

I was recently working on acpi_table_add() changes as a possible workaround for
a bug I was chasing. In the end, I dropped the idea of trying to use custom ACPI
tables for the specific problem I was working on, but in the process I made some
cleanups in the acpi_table_add() function, to make it more readable and easier
to change later.

Except for a small bug fix in the error handling (that isn't that important
because QEMU exits immediately if acpi_table_add() returns an error), no
behavior changes are introduced by this series, being just lots of code
movements.


Eduardo Habkost (11):
  acpi_table_add(): simplify acpi_tables on-demand initialization
  acpi_table_add(): extract acpi_tables init to separate function
  acpi_table_add(): rename 'len' to 'acpi_len'
  acpi_table_add(): introduce 'qemu_len' variable
  acpi_table_add(): extract ACPI header creation to separate function
  acpi_table_add(): rename 'qemu_len' to 'newlen'
  acpi_table_add(): eliminate 'allen' variable
  acpi_table_add(): eliminate 'start' variable
  acpi_table_add(): extract acpi_tables reallocation code to a separate
    function
  acpi_table_add(): use acpi_newtable_resize() return value
  acpi_table_add(): extract acpi_tables count update code to separate
    function

 hw/acpi.c |  185 ++++++++++++++++++++++++++++++++++++-------------------------
 1 file changed, 109 insertions(+), 76 deletions(-)

-- 
1.7.10.4




reply via email to

[Prev in Thread] Current Thread [Next in Thread]