[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] QEMU VNC Audio - All audio data null

From: agraham
Subject: Re: [Qemu-devel] QEMU VNC Audio - All audio data null
Date: Sat, 14 Jul 2012 23:16:14 +0100
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20111108 Fedora/3.1.16-1.fc14 Thunderbird/3.1.16

On 07/14/2012 09:09 PM, malc wrote:
On Sat, 14 Jul 2012, agraham wrote:

On 07/14/2012 06:20 PM, malc wrote:
On Sat, 14 Jul 2012, agraham wrote:

On 07/14/2012 01:55 PM, agraham wrote:
On 07/14/2012 11:44 AM, malc wrote:
On Sat, 14 Jul 2012, agraham wrote:


I've just rebuilt QEMU 1.0 (and all of its dependencies) and it has
the same
problem (zero bytes), so some incompatibility was introduced between
and 1.1.0.

Anyone got any clues ?

Please try to bisect the issue.


I cannot seem to get any further trying to find the source of this issue,
except to say that QEMU Audio over VNC used to work in QEMU 0.13 until
QEMU 15.1 then it appears to have stopped working as described above.

As i said, try bisecting, doesn't involce too many brainwaves only raw
machine power.

Well, the problem is I'm rebuilding from Fedora spec file and that contains
about 122 patches very many relating to spice that could cause the problem and
it's in one of these that the bug may be introduced.

Sorry, but i do not have Fedora and if you insist on using patched
version do talk to Fedora people.

FWIW i just built a fresh checkout and it works for me with my own

Which Client are you using?


Are you sure you're not using spice protocol?


I've just rebuilt qemu package from:

This is the latest Fedora 17 Package which builds qemu-kvm-1.1.0.tar.gz + a
bunch of patches.

The only patch I've included is:
0001-kvm-Enable-use-of-kvm_irqchip_in_kernel-in-hwlib-cod.patch, because it
will not compile without that patch. So it should pretty much match stock

I can confirm that the QEMU VNC Audio still does _not_ work and I get the
exact same results, i.e. when I read the sample format data from the socket it
contains the right amount of data, but the data contains zeros bytes, this
results in silence.

Also I found this:

The QEMU version they refer to is Fedora 16 which contains 0.15.x, which
confirms my own findings as stated above.

Get a vanilla git version and try to reproduce if it's reproducible -
bisect, if not try to seek help through Fedora channels.

I got the git version and created a tarbal and used the F17 Spec file to build all the packages - and it worked!

So this is now plain stock QEMU  (v1.1.50).

The problem still exists, exactly the same as previously described, and what I was expecting given my previous testing.

I also tried your client, and could not hear anything, the output was as follows:

# ./acap
server is `"QEMU (windows-xp-1)"'
Playing raw data 'stdin' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
underrun!!! (at least -1342018345912.717 ms long)
underrun!!! (at least -1342018345917.003 ms long)
underrun!!! (at least -1342018345912.526 ms long)

So I modified the acap.sh script to save all received data to a file as follows:

echo "$@" 1>&2
cat > file <&$inputfd
#aplay -t raw -c 2 -f S16_LE -r 44100 <&$inputfd

And this confirms that my original findings.

# hexdump -C file
00000000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
000bf690  00 00 00 00 00 00 00 00                           |........|

So now, I am assuming that you did _not_ "hear" actual sound, but assumed it was working because the output of the above script shows
data was being received.

Can you confirm this?

Does QEMU have a bug reporter ?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]