qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [RFC 04/19] rename cpu_x86_find_by_name to x86_cpu_build_fr


From: Eduardo Habkost
Subject: [Qemu-devel] [RFC 04/19] rename cpu_x86_find_by_name to x86_cpu_build_from_name
Date: Thu, 2 Aug 2012 23:59:11 -0300

The function does a lot more than just "finding" the CPU model, so name it
accordingly.

Signed-off-by: Eduardo Habkost <address@hidden>
---
 target-i386/cpu.c | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/target-i386/cpu.c b/target-i386/cpu.c
index 1154a34..be04e4b 100644
--- a/target-i386/cpu.c
+++ b/target-i386/cpu.c
@@ -1077,7 +1077,8 @@ static void x86_cpuid_set_tsc_freq(Object *obj, Visitor 
*v, void *opaque,
     cpu->env.tsc_khz = value / 1000;
 }
 
-static int cpu_x86_find_by_name(x86_def_t *x86_cpu_def, const char *cpu_model)
+static int cpu_x86_build_from_name(x86_def_t *x86_cpu_def,
+                                   const char *cpu_model)
 {
     unsigned int i;
     x86_def_t *def;
@@ -1356,7 +1357,7 @@ int cpu_x86_register(X86CPU *cpu, const char *cpu_model)
 
     memset(def, 0, sizeof(*def));
 
-    if (cpu_x86_find_by_name(def, cpu_model) < 0) {
+    if (cpu_x86_build_from_name(def, cpu_model) < 0) {
         return -1;
     }
     if (def->vendor1) {
-- 
1.7.11.2




reply via email to

[Prev in Thread] Current Thread [Next in Thread]