qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 1/2] gcc: rename CONFIG_PRAGMA_DISABLE_UNUSED_BU


From: Blue Swirl
Subject: Re: [Qemu-devel] [PATCH 1/2] gcc: rename CONFIG_PRAGMA_DISABLE_UNUSED_BUT_SET to CONFIG_PRAGMA_DIAGNOSTIC_AVAILABLE
Date: Sat, 12 Jan 2013 16:10:03 +0000

Thanks, applied.

On Wed, Jan 9, 2013 at 9:17 AM, Gerd Hoffmann <address@hidden> wrote:
> Signed-off-by: Gerd Hoffmann <address@hidden>
> ---
>  configure            |    6 +++---
>  coroutine-ucontext.c |    4 ++--
>  2 files changed, 5 insertions(+), 5 deletions(-)
>
> diff --git a/configure b/configure
> index 4f050ea..9357035 100755
> --- a/configure
> +++ b/configure
> @@ -3078,7 +3078,7 @@ int main(void) {
>  }
>  EOF
>  if compile_prog "-Werror" "" ; then
> -    pragma_disable_unused_but_set=yes
> +    pragma_diagnostic_available=yes
>  fi
>
>  ########################################
> @@ -3650,8 +3650,8 @@ if test "$linux_magic_h" = "yes" ; then
>    echo "CONFIG_LINUX_MAGIC_H=y" >> $config_host_mak
>  fi
>
> -if test "$pragma_disable_unused_but_set" = "yes" ; then
> -  echo "CONFIG_PRAGMA_DISABLE_UNUSED_BUT_SET=y" >> $config_host_mak
> +if test "$pragma_diagnostic_available" = "yes" ; then
> +  echo "CONFIG_PRAGMA_DIAGNOSTIC_AVAILABLE=y" >> $config_host_mak
>  fi
>
>  if test "$valgrind_h" = "yes" ; then
> diff --git a/coroutine-ucontext.c b/coroutine-ucontext.c
> index 2ed703a..a9c30e9 100644
> --- a/coroutine-ucontext.c
> +++ b/coroutine-ucontext.c
> @@ -200,7 +200,7 @@ Coroutine *qemu_coroutine_new(void)
>  }
>
>  #ifdef CONFIG_VALGRIND_H
> -#ifdef CONFIG_PRAGMA_DISABLE_UNUSED_BUT_SET
> +#ifdef CONFIG_PRAGMA_DIAGNOSTIC_AVAILABLE
>  /* Work around an unused variable in the valgrind.h macro... */
>  #pragma GCC diagnostic ignored "-Wunused-but-set-variable"
>  #endif
> @@ -208,7 +208,7 @@ static inline void 
> valgrind_stack_deregister(CoroutineUContext *co)
>  {
>      VALGRIND_STACK_DEREGISTER(co->valgrind_stack_id);
>  }
> -#ifdef CONFIG_PRAGMA_DISABLE_UNUSED_BUT_SET
> +#ifdef CONFIG_PRAGMA_DIAGNOSTIC_AVAILABLE
>  #pragma GCC diagnostic error "-Wunused-but-set-variable"
>  #endif
>  #endif
> --
> 1.7.1
>
>



reply via email to

[Prev in Thread] Current Thread [Next in Thread]