qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PATCH RFT v3 0/5] usb: QOM realize support for SysBus EHCI


From: Andreas Färber
Subject: [Qemu-devel] [PATCH RFT v3 0/5] usb: QOM realize support for SysBus EHCI and FUSBH200
Date: Sun, 17 Feb 2013 17:48:18 +0100

Hello Gerd and Kuo-Jung,

This series combines my revoked QOM realize patch with Kuo-Jung's series
adding Faraday FUSBH200 EHCI and my Tegra2 EHCI.

To facilitate adaptations for the Faraday EHCI, I am taking my QOM realize
factoring further. This avoids having to introduce a class for FUSBH200 by
reusing QOM instance_init infrastructure rather than realize.

It simplifies overriding portscbase and portnr by setting the current values
in ehci_sysbus_class_init rather than per subclass. This means less values to
specify for Tegra EHCI.

It also cleans up FUSBH200 code a little by introducing enum values for the
register offsets (possibly to be moved to a header one day for qtest).
Obviously I have no clue whether the names match any spec, please check,
I made a guess based on the code comments.

Only lightly tested, seeing that -device usb-ehci (PCI) doesn't segfault.

Regards,
Andreas

v1 -> v3:
* Renamed realizefn -> realize following a discussion with Anthony.
* Rename usb_ehci_initfn -> usb_ehci_realize.
* Split off instance_init from initfn / realize, with Faraday in mind.
* Incorporated Kuo-Jung's v1 EHCI refactoring + FUSBH200 EHCI.
* Merged Kuo-Jung's v2 PCI initialization.

>From Kuo-Jung's FUSBH200/PORTSC v1/v2:
* Moved old portscbase and portnr values into base class_init.
* Moved mem_vendor field to new FUSBH200EHCIState.
* Replace vendor init callback with derived instance_init.
* Introduced enum for vendor registers.
* Replace magic number 0x34 with formula, so that it doesn't deviate.

>From my Tegra2 FYI patch:
* None.

Cc: Gerd Hoffmann <address@hidden>
Cc: Kuo-Jung Su <address@hidden>
Cc: Peter Crosthwaite <address@hidden>
Cc: Igor Mitsyanko <address@hidden>
Cc: Liming Wang <address@hidden>

Andreas Färber (3):
  usb/hcd-ehci-sysbus: Convert to QOM realize
  usb/hcd-ehci: Split off instance_init from realize
  usb/hcd-ehci: Add Tegra2 SysBus EHCI device

Kuo-Jung Su (2):
  usb/hcd-ehci: Replace PORTSC macros with variables
  usb/hcd-ehci: Add Faraday FUSBH200 support

 hw/usb/hcd-ehci-pci.c    |   23 ++++++---
 hw/usb/hcd-ehci-sysbus.c |  121 +++++++++++++++++++++++++++++++++++++++++++---
 hw/usb/hcd-ehci.c        |   47 +++++++++++-------
 hw/usb/hcd-ehci.h        |   28 ++++++++---
 4 Dateien geändert, 180 Zeilen hinzugefügt(+), 39 Zeilen entfernt(-)

-- 
1.7.10.4




reply via email to

[Prev in Thread] Current Thread [Next in Thread]