[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] VFIO-VGA Issue

From: deniv
Subject: [Qemu-devel] VFIO-VGA Issue
Date: Tue, 9 Apr 2013 08:22:45 -0400 (EDT)
User-agent: SquirrelMail/1.4.13


I've tried passing through my ASUS Radeon HD7750, but qemu just hogs 100%
of one core and stops. Since the display didn't light up, I couldn't see
how far Win 7 boot went. For a Linux guest I tried redirecting kernel
messages to serial console, but there was nothing (qemu stops even before
kernel start?).

Also, this GPU is kinda troublesome: it doesn't work with the proprietary
driver if VT-d is enabled in BIOS (boot process stops with "dmar: DRHD:
handling fault status reg 3"). The GPU works with the FOSS driver, though.
Could this somehow be related to the passthrough issue?

Anyway, VT-d in pci-assign mode works for network adapters on this host.
It runs kernel 3.9.0-rc5 (with vfio-vga enabled), qemu git from yesterday,
and seabios 1.7.2. The host has no driver installed for the GPU. Before
assiging it to qemu I'd run "echo '1002 683f' >
/sys/bus/pci/drivers/vfio-pci/new_id" and the same for the associated HDMI
device. Command line:
qemu-kvm -machine q35,accel=kvm \
         -cpu host -smp 4 -m 2G \
         -vga none -display none \
         -kernel /kvm/kernel-3.7.8 -append 'root=/dev/vda console=ttyS0' \
index=0,media=disk,cache=none,if=virtio,aio=native,file=/dev/vg3/gpu \
         -device vfio-pci,host=01:00.0,x-vga=on \
         -device vfio-pci,host=01:00.1 \
         -serial telnet:,server

reply via email to

[Prev in Thread] Current Thread [Next in Thread]