[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [Bug 955379] Re: cmake hangs with qemu-arm-static

From: Luke Kim
Subject: [Qemu-devel] [Bug 955379] Re: cmake hangs with qemu-arm-static
Date: Fri, 12 Apr 2013 10:25:24 -0000

Janne Karhunen: Do you think if it is correct that return 0 when 
ts->signal_pending is true and select() returns '0' (timeout)? Because the 
caller doesn't expect to return select() with 0, should we return other error 
values such as EINTR?
When I modified you patch to return EINTR if select() return '0' when 
ts->signal_pending is true, it worked fine with me.

You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.

  cmake hangs with qemu-arm-static

Status in QEMU:
Status in Linaro QEMU:
Status in “qemu-linaro” package in Ubuntu:

Bug description:
  I'm using git commit 3e7ecd976b06f... configured with --target-list
  =arm-linux-user --static in a chroot environment to compile some
  things. I ran into this problem with both pcl and opencv-2.3.1. cmake
  consistently freezes at some point during its execution, though in a
  different spot each time, usually during a step when it's searching
  for some libraries. For instance, pcl most commonly stops after:

  -- Boost version: 1.46.1
  -- Found the following Boost libraries:
  --   system
  --   filesystem
  --   thread
  --   date_time
  -- checking for module 'eigen3'
  --   found eigen3, version 3.0.1

  which is perplexing because it freezes after finding what it wants,
  not during the search. When it does get past that point, it does so
  almost immediately but freezes somewhere else.

  I'm using 64-bit Ubuntu 11.10 with kernel release 3.0.0-16-generic
  with an Intel i5.

To manage notifications about this bug go to:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]