[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [libvirt]virtio serial device problem

From: Li Zhang
Subject: [Qemu-devel] [libvirt]virtio serial device problem
Date: Tue, 07 May 2013 15:20:16 +0800
User-agent: Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/20130329 Thunderbird/17.0.5

Hi all,

When we use the latest version of QEMU to build ovirt,
we get this error reported from libvirt.

qemu-system-ppc64: -device
Bus 'virtio-serial0.0' is full
qemu-system-ppc64: -device
Bus 'virtio-serial0.0' not found

Libvirt helps create QEMU command line and put virtserialport device to bus virtio-serial0.0.
For latest version of QEMU, the bus type is changed.

(qemu) info qtree
bus: main-system-bus
  type System
  dev: spapr-pci-host-bridge, id ""
    index = 0
    buid = 0x800000020000000
    liobn = 0x80000000
    mem_win_addr = 0x100a0000000
    mem_win_size = 0x20000000
    io_win_addr = 0x10080000000
    io_win_size = 0x10000
    msi_win_addr = 0x10090000000
    irq 0
    bus: pci
      type PCI
      dev: virtio-serial-pci, id "virtio-serial0"
        ioeventfd = on
        vectors = 2
        class = 0x780
        indirect_desc = on
        event_idx = on
        max_ports = 31
        addr = 03.0
        romfile = <null>
        rombar = 1
        multifunction = off
        command_serr_enable = on
        class Class 0780, addr 00:03.0, pci id 1af4:1003 (sub 1af4:0003)
        bar 0: i/o at 0xffffffffffffffff [0x1e]
        bar 1: mem at 0xffffffffffffffff [0xffe]
        bus: virtio-serial0.0
          type virtio-pci-bus
          dev: virtio-serial-device, id ""
            max_ports = 31
            bus: virtio-serial-bus.0
              type virtio-serial-bus
              dev: virtserialport, id "channel1"
                chardev = charchannel1
                nr = 2
                name = "org.qemu.guest_agent.0"
                port 2, guest off, host off, throttle off
              dev: virtserialport, id "channel0"
                chardev = charchannel0
                nr = 1
                name = "com.redhat.rhevm.vdsm"
                port 1, guest off, host off, throttle off

But we tried to replace virtio-serial0.0 with virtio-serial-bus.0,
SLOF crashes. It still doesn't work at all.

Does anyone know how to use virtserialport in QEMU command line?
If configuration is changed in QEMU, libvirt also needs to change it accordingly.

Thanks. :)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]