[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v2 2/3] block: add block-backup QMP command

From: Kevin Wolf
Subject: Re: [Qemu-devel] [PATCH v2 2/3] block: add block-backup QMP command
Date: Mon, 13 May 2013 10:23:27 +0200
User-agent: Mutt/1.5.21 (2010-09-15)

Am 11.05.2013 um 05:34 hat Eric Blake geschrieben:
> On 05/08/2013 06:49 AM, Kevin Wolf wrote:
> > Am 29.04.2013 um 09:42 hat Stefan Hajnoczi geschrieben:
> >> @block-backup
> >>
> > drive-backup would probably be a more consistent naming. We would then
> > still have block-backup for a future low-level command that doesn't
> > create everything by itself but takes an existing BlockDriverState (e.g.
> > created by blockdev-add).
> At least it would match why we named a command 'drive-mirror' instead of
> 'block-mirror'.
> Hmm, looking at qapi-schema.json, I wonder if we can rename
> 'BlockdevAction' to 'TransactionAction' as used in the @transaction
> command.  It wouldn't change what is sent over the wire in JSON, and
> until we have full introspection, there is no visibility into the type
> name used.  Changing the name now would let it be more generic to adding
> future transaction items that are not blockdev related.

Good point, I never realised that once we have schema introspection,
doing such changes is harder. I'm all for it - it's bad enough that we
have specifically block jobs instead of just background jobs, we
shouldn't repeat the same mistake with transactions.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]