[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [qemu-devel][libvirt] Default machine type setting for

From: Li Zhang
Subject: Re: [Qemu-devel] [qemu-devel][libvirt] Default machine type setting for ppc64
Date: Tue, 21 May 2013 16:45:21 +0800
User-agent: Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/20130329 Thunderbird/17.0.5

On 2013年05月21日 16:31, Peter Maydell wrote:
On 21 May 2013 09:19, Li Zhang <address@hidden> wrote:
We encounter this problem in openstack which always use
default machine type. Currently, QEMU sets mac99 as default
setting for ppc64 but it doesn't work on our platform at all.

I tried to fix this in libvirt which it is not acceptable because
libvirt only considers to get default setting from QEMU.
This will need to be fixed for ARM -- the whole idea of there
being a sensible "default machine type" and it being the one
QEMU starts by default is pretty x86-centric. libvirt needs
to have support for specifying which machine to use.
Ah, libvirt does have support for specifying one machine type.

I mean that libvirt set default according to QEMU's default setting,
and management tools are dependent on this default setting without
users' specified setting.

I tried to change the default setting according to ppc64 platform
in libvirt, but it is not accepted.
(There is consideration of changing the default ppc64
machine, as it happens; but in general you can't rely
on QEMU doing what you want if you don't tell it
specifically which board you wanted.)
I see.  Thanks for your suggestion. :)

-- PMM

reply via email to

[Prev in Thread] Current Thread [Next in Thread]