[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Win32 QEMU binaries built from MinGW fail (access violation

From: Dan
Subject: [Qemu-devel] Win32 QEMU binaries built from MinGW fail (access violation)
Date: Fri, 24 May 2013 20:56:57 -0500

I've been trying to build QEMU source directly with MinGW.  The
compile/link works but there are tons of warnings (mostly Wformat).
Once I try to run the binaries in Windows though, I quickly hit access
violations once the HD image is mounted.  I've tested on the
linux-0.2.img.bz2 so that I can be consistent with others.  The
violations bounce around based on the image and emulation.  I've tried
with -nographic to try to rule out SDL.dll.  I'm at a loss, and
beginning to wonder if 100's of Wformat errors need to be patched one
by one to have a run-able windows binary.

What I'm confused by is that both qemu.org (ref1) and wikibooks.org
(ref2) seem to imply that there are no special MinGW patches.  I've
also found many sites hosting valid QEMU win32 binaries like
omledom.com (ref3).  I've even ensured that my ./configure settings
match theirs (omledom), but of course I have no way to know if they
are compiliing FROM windows FOR windows, or FROM linux FOR windows.

Here's is an abridged list of my process.

install cygwin to for wget and unzip, though nothing is in the PATH varable.
wget mingw-get-inst-20120426.exe
wget python-2.6.6.msi
wget gtk+-bundle_2.24.10-20120208_win32.zip
wget SDL-devel-1.2.15-mingw32.tar.gz
wget qemu-1.4.1.tar.bz2
wget linux-0.2.img.bz2

install mingw-get-inst-20120426.exe
install python-2.6.6.msi
unzip gtk+-bundle_2.24.10-20120208_win32.zip to c:\MinGW
unzip SDL-devel-1.2.15-mingw32.tar.gz to c:\MinGW\msys\1.0\src
unzip qemu-1.4.1.tar.bz2 to c:\MinGW\msys\1.0\src
decompress linux-0.2.img.bz2 to c:\MinGW\msys\1.0\bld

launch msys prompt && cd /usr/src/SDL && make native
launch msys prompt && cd /usr/src/qemu
./configure --python=c:/Python26/python.exe --prefix=/usr/bld
make && make install && cd /usr/bld
./qemu-system-i386.exe linux-0.2.img

Observe an access violation in qemu-system-i386.exe within 5 seconds.

Am I the only one compiling qemu FROM windows FOR windows?

Also, just for grins, I replace my copy of qemu-system-i386.exe with
the one from omledom and things work without any issues.  I've also
tried the qemu 1.5 repositories and this weeks .git snapshot.  All
fail with similar errors.

I've also done this on two machines, an x86 Windows Vista system and
an x64 Windows 8 system.  Same results on both.

ref1: http://wiki.qemu.org/Hosts/W32
ref2: http://en.wikibooks.org/wiki/QEMU/MinGW
ref3: http://www.omledom.com/

Long explanation at:


reply via email to

[Prev in Thread] Current Thread [Next in Thread]