[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [Bug 1180924] Re: fails to handle a usb serial port with a

From: Rostislav Devyatov
Subject: [Qemu-devel] [Bug 1180924] Re: fails to handle a usb serial port with a specific vendorid
Date: Mon, 27 May 2013 09:01:08 -0000

I think the ability to specify a different vendorid + deviceid can be
useful. Suppose there is a USB device such that the specifications are
open and officially published, but the driver is proprietary. (As far as
I know, this is similar to the situation with ATI video cards, but they
are not USB devices.) And I suspect that the driver is buggy (i. e. it
does not send the data according to the specifications). I want to
figure out where exactly it works incorrectly to submit a bug report to
the developer of the driver. Or suppose I have a physical device, but it
works a bit incorrectly. I want to figure out where exactly the problem
is, in the driver or in the device. Since I am not sure that the device
is OK, I don't want to write my own driver and interact with the device,
maybe I will damage it even more. In both cases, I can emulate the
device according to the specifications, install the driver in a guest
system, and then see whether the driver sends correct data or where and
when exactly the data are incorrect.

Anyway, I think it is more or less ok if qemu crashes right after it
starts due to bad command line parameters (nevertherless, the
functionality lost this way could be useful as I explained). But I think
enters a bad command in the machine's control terminal, unless the user
explicitly requests termination (e. g. enters the q command).

You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.

  fails to handle a usb serial port with a specific vendorid

Status in QEMU:

Bug description:
  If I run qemu-system-i386 with arguments
  -usb -usbdevice serial:vendorid=1221:pty
  (this is what the documentation says about how I shoud add a usb device which 
has a serial port interface and which has a specific vendor id, I used the 
documentation located here:
  ), it says 
  char device redirected to /dev/pts/<something> (label usbserial0)
  qemu-system-i386: -usbdevice serial:vendorid=1221:pty: Property '.vendorid' 
not found
  and exits. Moreover, if I try to add such a device to a running machine by 
typing usb_add serial:vendorid=1221:pty in the machine's control terminal (to 
reach it, I press ctrl-alt-2), qemu also writes 
  char device redirected to /dev/pts/<something> (label usbserial0)
  to the terminal where I run it from and exits. To the quest OS this looks 
like a power failure which causes all the programs inside the virtual machine 
to lose their unsaved data.
  I have tested this with qemu-1.5.0-rc2, actually, the issue occured in a 
similar way since 1.0.1, but did not occur in 0.11.1.
  The issue is reproducible always, even if I don't specify any hard disk in 
the command line, i. e.
  $ qemu-system-i386 -usb -usbdevice serial:vendorid=1221:pty
  , so I believe it is guest OS -independent.

To manage notifications about this bug go to:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]