[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] virtio-serial-pci very expensive during live migration

From: Chris Friesen
Subject: Re: [Qemu-devel] virtio-serial-pci very expensive during live migration
Date: Thu, 8 May 2014 09:40:41 -0600
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.4.0

On 05/08/2014 07:47 AM, Amit Shah wrote:

Chris, I just tried a simple test this way:

./x86_64-softmmu/qemu-system-x86_64 -device virtio-serial-pci -device 
virtserialport -S -monitor stdio -nographic

and it didn't crash for me.  This was with qemu.git.  Perhaps you can
try in a similar way.

I just tried it with the "stable-1.4" branch from upstream with my first patch added on.

Incidentally, to compile on Fedora 19 I had to delete "include/libfdt_env.h" in the qemu package since it was overriding the version from libfdt in the host, causing errors like:

/usr/include/fdt.h:58:2: error: unknown type name ‘fdt32_t’
  fdt32_t magic;    /* magic word FDT_MAGIC */

Anyway, it seems to boot up okay, which is better than what I was getting before. I ran it as:

qemu-system-x86_64 -machine accel=kvm -m 1000 guest.img -device virtio-serial -chardev socket,path=/tmp/foo,server,nowait,id=foo -device virtserialport,chardev=foo,name=myfoo

My earlier version was using a yocto-modified version of qemu, further modified locally. There's probably a bug in there somewhere.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]