qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v2 10/19] qtest/ahci: add ahci_write_fis


From: Stefan Hajnoczi
Subject: Re: [Qemu-devel] [PATCH v2 10/19] qtest/ahci: add ahci_write_fis
Date: Thu, 5 Feb 2015 13:29:27 +0000
User-agent: Mutt/1.5.23 (2014-03-12)

On Tue, Feb 03, 2015 at 04:46:30PM -0500, John Snow wrote:
> Similar to ahci_set_command_header, add a helper that takes an
> in-memory representation of a command FIS and writes it to guest
> memory, handling endianness as-needed.
> 
> Signed-off-by: John Snow <address@hidden>
> ---
>  tests/ahci-test.c   |  2 +-
>  tests/libqos/ahci.c | 10 ++++++++++
>  tests/libqos/ahci.h |  1 +
>  3 files changed, 12 insertions(+), 1 deletion(-)
> 
> diff --git a/tests/ahci-test.c b/tests/ahci-test.c
> index 211274e..658956d 100644
> --- a/tests/ahci-test.c
> +++ b/tests/ahci-test.c
> @@ -728,7 +728,7 @@ static void ahci_test_identify(AHCIQState *ahci)
>      g_assert_cmphex(ahci_px_rreg(ahci, i, AHCI_PX_IS), ==, 0);
>  
>      /* Commit the Command FIS to the Command Table */
> -    memwrite(table, &fis, sizeof(fis));
> +    ahci_write_fis(ahci, &fis, table);
>  
>      /* Commit the PRD entry to the Command Table */
>      memwrite(table + 0x80, &prd, sizeof(prd));
> diff --git a/tests/libqos/ahci.c b/tests/libqos/ahci.c
> index ec72627..7336781 100644
> --- a/tests/libqos/ahci.c
> +++ b/tests/libqos/ahci.c
> @@ -464,6 +464,16 @@ void ahci_destroy_command(AHCIQState *ahci, uint8_t px, 
> uint8_t cx)
>      ahci->port[px].prdtl[cx] = 0;
>  }
>  
> +void ahci_write_fis(AHCIQState *ahci, RegH2DFIS *fis, uint64_t addr)
> +{
> +    RegH2DFIS tmp = *fis;
> +
> +    /* All other FIS fields are 8 bit and do not need to be flipped. */
> +    tmp.count = cpu_to_le16(tmp.count);
> +
> +    memwrite(addr, &tmp, sizeof(tmp));
> +}

This patch looks wrong because tmp.count is byteswapped now but not
before.  It actually works because the value is 0 so we never bothered
to assign it explicitly.

I do wonder about the 'aux' field in the FIS struct.  It's uint32_t.
Although the tests never access it, should that field be byteswapped?

Stefan

Attachment: pgpnzPNAX9NN0.pgp
Description: PGP signature


reply via email to

[Prev in Thread] Current Thread [Next in Thread]