[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Revert commit 5af35d7feccaa7d26b72c6c3d14116421d736b36

From: Hans de Goede
Subject: Re: [Qemu-devel] Revert commit 5af35d7feccaa7d26b72c6c3d14116421d736b36 - "usb-host-libusb: Fix reset handling"
Date: Wed, 11 Feb 2015 08:29:48 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.4.0


On 10-02-15 22:02, Dennis Ostermann wrote:
Hello Hans,

thanks for taking care.

09-02-15 09:09, Hans de Goede wrote:

On 09-02-15 22:09, Dennis Ostermann wrote:
Hi there,

please revert commit 5af35d7feccaa7d26b72c6c3d14116421d736b36 - "usb-host-libusb: 
Fix reset handling"

This breaks usb pass through of FTDI based usb devices:

On the host:

lsusb | grep FT2232
Bus 003 Device 008: ID 0403:6010 Future Technology Devices International, Ltd 

~/qemu-install/bin$ sudo ./qemu-system-x86_64 -monitor 
telnet:,server,nowait -hda /dev/sdd2 -redir tcp:20022::22 
--enable-kvm -cpu host -smp 4 -vga vmware --vnc :0 -m 8192  -usb -device 
usb-ehci,id=ehci -device usb-host,bus=ehci.0,vendorid=0x0403,productid=0x6010
WARNING: Image format was not specified for '/dev/sdd2' and probing guessed raw.
           Automatically detecting the format is dangerous for raw images, 
write operations on block 0 will be restricted.
           Specify the 'raw' format explicitly to remove the restrictions.
libusbx: error [_get_usbfs_fd] libusbx couldn't open USB device 
/dev/bus/usb/003/005: No such file or directory
libusbx: error [_get_usbfs_fd] libusbx couldn't open USB device 
/dev/bus/usb/003/006: No such file or directory
libusbx: error [_get_usbfs_fd] libusbx couldn't open USB device 
/dev/bus/usb/003/007: No such device

The device gets reset again and again and is re-enumerated every time and 
finally not passed through.
This looks like the device drops of the bus when it is reset, that is not 
normal behavior,
there seems to be something unique to your setup causing this. Have you tried 
this on
multiple machines / different usb ports on your pc ? This may be something 
weird with the usb
controller in your machine.
The machine uses Intel H97 chipset, so not that unique. I tried every port, 
every USB BIOS, with and without hub, it doesn't make any difference. But 
you're right, I also tried it on a T61 with Intel 900 series chipset and it 
worked alright. But this is an 'old' USB 2.0 chipset. I'll try on another box 
with USB 3.0 chipset tomorrow, if I can get one.

Ok, lets wait and see what results another model usb-3 capable pc / laptop gets 
us, I've
the feeling that this is a machine specific issue. Normally a usb-reset should 
not cause
a device disconnect as you're seeing here.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]